SMSSP3_OM07_MPGD.cover

Guía del módulo de administración de Microsoft Systems Management Server 2003 Service Pack 3 para Operations Manager 2007

Microsoft Corporation

Fecha de publicación: mayo de 2007

Comentarios

Envíe sugerencias y comentarios acerca de este documento a smsdocs@microsoft.com. Incluya el nombre de la guía del módulo de administración con sus comentarios.


SMSSP3_OM2007_MPGuide.copy

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the companies, organizations, products, domain names, e-mail addresses, logos, people, places, and events depicted in examples herein are fictitious. No association with any real company, organization, product, domain name, e-mail address, logo, person, place, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2007 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows Server, and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

All other trademarks are property of their respective owners.


Módulo de administración de Microsoft Systems Management Server 2003 para Operations Manager 2007

Éste es el módulo de administración de Microsoft® Systems Management Server 2003 para Operations Manager 2007. El módulo de administración ofrece capacidades nuevas y mejoradas para la supervisión de SMS 2003.

Recursos del módulo de administración

Para obtener más información acerca de las características y los recursos, vea los siguientes temas.

Introducción al módulo de administración de Systems Management Server 2003

  • Escenarios de supervisión del módulo de administración
  • Implementación del módulo de administración de SMS 2003
  • Realización de tareas de operaciones para el módulo de administración de SMS 2003
  • Solución de problemas del módulo de administración de SMS 2003
  • Referencia para el módulo de administración de Microsoft Systems Management Server 2003


Introducción al módulo de administración de Systems Management Server 2003
Vea también

Esta guía le permitirá familiarizarse con la información técnica y de implementación del módulo de administración de SMS 2003. Con esta información puede planear la implementación del módulo de administración, comprender las características que ofrece el módulo de administración y aprender a usar esas características para beneficiar a su organización de TI.

El módulo de administración de System Center Operations Manager 2007 para SMS ofrece capacidades mejoradas para la supervisión de SMS 2003, tales como las siguientes:

  • Supervisión del inicio y la detención de todos los servicios SMS 2003, incluidos los servicios dependientes críticos como Instrumental de administración de Windows (WMI), Internet Information Services (IIS), Servicio de transferencia inteligente en segundo plano (BITS) y Microsoft SQL Server™.
  • Alertas para el administrador de SMS acerca de mensajes de estado de SMS críticos.
  • Supervisión de trabajos acumulados de registros de datos de detección (DDR), inventario de hardware, inventario de software, mensajes de estado y disponibilidad de software en servidores de sitios principales y puntos de administración.
  • Supervisión del uso de recursos del sistema.
  • Supervisión de tasas de procesamiento.
  • Supervisión de las tendencias de rendimiento de muchos contadores de rendimiento de SMS mediante el uso de vistas e informes.
  • Información del producto para todas las alertas y reglas de procesamiento.
  • Detección de todos los equipos y grupos de equipos de SMS 2003.
  • Vistas.
  • Informes que muestran el rendimiento, la disponibilidad y la configuración de los puntos de administración y grupos de servidores de SMS 2003. Incluyen informes vinculados que proporcionan informes mejorados de System Center Operations Manager 2007 para tendencias de disponibilidad, rendimiento y configuración.
  • Supervisión del módulo de características de administración de dispositivos.
  • Tareas para ejecutar las aplicaciones de la consola de administrador de SMS.
  • Vista de estado que contiene el estado de todas las funciones del servidor SMS y del cliente avanzado de SMS.
  • Detección de servicios de información importante del servidor SMS y del cliente SMS.
  • Supresión de las alertas de servicio no disponible que aparecen con la ejecución de la copia de seguridad de sitios de SMS.
  • Diagrama de topología de la jerarquía de sitios de SMS (se necesita SMS 2003 Service Pack 3).
  • SMS 2003 Service Pack 3 (SP3) configurable que avisa de errores de ejecución del programa distribuido a través de las propiedades del programa de SMS.

Para obtener más información acerca de la supervisión de escenarios y características, vea Escenarios de supervisión del módulo de administración. El módulo de administración de SMS 2003 no está diseñado para lo siguiente:

  • Proporcionar la supervisión de SMS 1.2, SMS 2.0 o SMS 2003 SP2.
  • Supervisar entornos de SMS mixtos. Los entornos mixtos tienen instalaciones de SMS 1.2, SMS 2.0 y SMS 2003 que se ejecutan en paralelo.
  • Supervisión limitada de equipos sólo cliente de SMS que ejecutan el cliente avanzado de SMS.
  • Proporcionar una solución de supervisión lista para usar que administre cualquier instalación de SMS 2003 sin ninguna modificación. Los umbrales de las reglas son diferentes para cada instalación de SMS 2003 y los clientes deben personalizar las reglas.

En esta sección

Novedades de esta actualización

Conocimientos recomendados

Configuración de SMS compatible

Vea también

Conceptos

Escenarios de supervisión del módulo de administración
Implementación del módulo de administración de SMS 2003

Otros recursos

Realización de tareas de operaciones para el módulo de administración de SMS 2003
Solución de problemas del módulo de administración de SMS 2003
Referencia para el módulo de administración de Microsoft Systems Management Server 2003


Novedades de esta actualización

El módulo de administración de Microsoft Systems Management Server 2003 para Operations Manager 2007 incluye el modo de mantenimiento. El modo de mantenimiento suprime las alertas de Operations Manager enviadas por equipos cliente cuando el software de SMS se ejecuta en el equipo cliente.

Actualización del modo de mantenimiento para SMS 2003

Cuando Systems Management Server 2003 distribuye software a los equipos, a menudo es necesario deshabilitar temporalmente las alertas basadas en reglas de Operations Manager generadas por el equipo de destino. Por ejemplo, la implementación de revisiones y actualizaciones de seguridad en servidores puede necesitar el cierre de subprocesos y servicios. Si los subprocesos o servicios de estos servidores son supervisados por un módulo de administración, es posible que se generen muchas alertas de Operations Manager y que se sobrecargue el servidor de Operations Manager.

La casilla de verificación Disable MOM alerts while this program runs suspende las alertas de Operations Manager hasta que el software distribuido ha terminado. El administrador de SMS puede establecer esta casilla de verificación en las propiedades del programa del paquete de SMS. Al establecer esta opción, se suprimen las alertas de Operations Manager en todos los módulos de administración que tienen como destino el equipo cliente mientras el equipo cliente ejecuta ese programa.

Si se selecciona esta opción, cuando el anuncio se ejecuta en el equipo de destino, el agente Operations Manager pasa al modo de mantenimiento. El agente de SMS también ofrece una opción de tiempo de espera para el agente Operations Manager. Después de que el anuncio se ejecute en el equipo de destino, el agente cliente de SMS reanudará la supervisión del agente Operations Manager en el equipo. Los sucesos que desencadenen alertas después de este momento se comunicarán con normalidad.

Si la distribución de software no se ejecuta en el equipo de destino, tienen lugar las siguientes acciones:

  • Si la distribución devuelve un código de error, el agente de SMS quitará el agente Operations Manager del modo de mantenimiento como si la distribución se hubiera realizado correctamente.
  • Si se produce un error inesperado en la distribución y el agente de SMS no recibe ningún código de error en un intervalo de tiempo predefinido, el agente Operations Manager saldrá del modo de mantenimiento.

Habilitación del modo de mantenimiento para un programa de SMS 2003

Use el siguiente procedimiento para habilitar el modo de mantenimiento en equipos cliente mientras se ejecutan programas de SMS 2003.

Para habilitar el modo de mantenimiento para un programa de SMS 2003

  1. En la consola de Systems Management Server, navegue a Systems Management Server / Site Database - <nombre del servidor de sitio> / Packages.

  2. En el panel de detalles, haga clic con el botón secundario en Program y, a continuación, haga clic en Propiedades.

  3. En el cuadro de diálogo Program Properties, haga clic en la ficha MOM.

  4. Seleccione Disable MOM alerts while this program runs y, a continuación, haga clic en Aceptar.

Después de habilitar el modo de mantenimiento del programa de SMS 2003, el equipo cliente pasará al modo de mantenimiento cuando el paquete de SMS 2003 se distribuya y ejecute.

Nota
El tiempo de espera del modo de mantenimiento se establece en el cuadro de diálogo Program Properties de la ficha Requirements con la propiedad Maximum allowed runtime seleccionada.

Topología de sitios de SMS 2003

Los diagramas de jerarquías de SMS 2003 en Microsoft Operations Manager (MOM) 2005 se han reemplazado por una jerarquía de sitios de SMS 2003. La vista de jerarquía muestra ahora las funciones de servidor en la vista de topología.

Eliminación de secuencias de comandos de configuración

Puesto que SMS 2003 SP2 o posterior es la versión recomendada de SMS, se han eliminado las secuencias de comandos de configuración.

Informes de SMS 2003

SMS 2003 contiene nuevos informes que se centran en los contadores de rendimiento por función del sistema de sitio y los contadores de rendimiento por contador de procesamiento de objetos, como los contadores relacionados con DDR. Para obtener más información acerca de los nuevos informes, vea Informes de SMS 2003.

Vea también

Conceptos

Informes de SMS 2003
Secuencias de comandos de SMS 2003


Conocimientos recomendados

Para implementar y ejecutar el módulo de administración de SMS 2003, se recomienda tener los conocimientos y las habilidades siguientes:

  • Conocimiento práctico de las características de supervisión de Operations Manager 2007. Para obtener más información acerca de Operations Manager 2007, vea la página web de Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).
  • Comprensión de la arquitectura de diseño de Operations Manager 2007 y la arquitectura de diseño que se implementa en su organización.
  • Conocimiento del proceso recomendado para implementar módulos de administración como se describe en la guía de implementación de System Center Operations Manager 2007.
  • Conocimiento práctico de los conceptos y la terminología de SMS. Para obtener más información acerca de SMS 2003, vea la página web de la documentación del producto de SMS 2003 (http://go.microsoft.com/fwlink/?linkid=9502).

Vea también

Conceptos

Escenarios de supervisión del módulo de administración
Implementación del módulo de administración de SMS 2003

Otros recursos

Realización de tareas de operaciones para el módulo de administración de SMS 2003


Configuración de SMS compatible

Los requisitos de SMS 2003 y Systems Center Operations Manager 2007 se pueden consultar en sus respectivas guías de implementación. El módulo de administración de SMS 2003 supervisa SMS 2003. Se recomienda SMS 2003 SP2 y versiones posteriores. Para usar SMS 2003 SP1 es necesario ejecutar una secuencia de comandos de sello.

Para habilitar el modo de mantenimiento durante la distribución de software y la topología de asignación con Operations Manager 2007, se necesita SMS 2003 SP3 o posterior.

El módulo de administración de SMS 2003 no supervisa SMS 1.2, SMS 2.0 ni el Administrador de configuración 2007.

Vea también

Otros recursos

Referencia para el módulo de administración de Microsoft Systems Management Server 2003
Solución de problemas del módulo de administración de SMS 2003


Escenarios de supervisión del módulo de administración

Microsoft® Systems Management Server (SMS) 2003 ofrece capacidades nuevas y mejoradas para la supervisión de SMS 2003. En las siguientes secciones se describen los escenarios principales que admite el módulo de administración de SMS 2003 y sus características.

Disponibilidad de servicio

Detección de servicios

Supervisión de disponibilidad

Supervisión de estado

Compatibilidad de supervisión sin agente

Supervisión de umbral de rendimiento

Supervisión de rendimiento

Supervisión de mensajes de estado de SMS críticos

Supervisión de sistema de sitio

Supervisión de volcado ejecutivo

Supervisión de trabajos acumulados

Supervisión del estado general

Supervisión de la administración de revisiones de SMS

Supervisión de copias de seguridad del sitio de SMS

Información del producto para todas las alertas

Grupos de equipos de todas las funciones de servidor y cliente de SMS 2003

Supervisión expandida

Estado de ejecución del programa de distribución de software

Disponibilidad de servicio

La disponibilidad de servicio supervisa la disponibilidad de los servicios de SMS 2003 mediante la característica de disponibilidad de servicio de System Center Operations Manager 2007 y los sucesos del administrador de control de servicios del registro del sistema de sucesos de NT. La supervisión de disponibilidad de servicio genera:

  • Una alerta cuando los servicios basados en SMS se detienen en los sistemas de sitio SMS.
  • Una alerta cuando un servicio dependiente de SMS crítico, como el Instrumental de administración de Windows (WMI), se detiene o no se puede iniciar en sistemas de sitio de SMS.
  • Una alerta cuando otros servicios dependientes de SMS, como Microsoft SQL Server™, Internet Information Services (IIS) y el Servicio de transferencia inteligente en segundo plano (BITS) se detienen o no se pueden iniciar en sistemas de sitio de SMS.
  • Una alerta, cuando el servicio de copia de seguridad de sitio de SMS se inicia y se detiene, para poder supervisar las duraciones de la copia de seguridad y correlacionar los sucesos de detención de otros servicios de SMS con la copia de seguridad de sitio de SMS.

Detección de servicios

La detección de servicios es el proceso de detección de datos, funciones de servidor y componentes en equipos administrados. La detección de servicios devuelve información acerca de los servidores SMS y los clientes avanzados de SMS. También es compatible con la presentacion de las funciones de servidores SMS y cliente SMS en la vista de supervisión de estado.

Se recopilan datos de detección de servicios específicos del servidor y se empiezan a mostrar en la consola de System Center Operations después de implementar el módulo de administración. Las características que necesitan funciones de identificación, grupos de equipos y equipos de destino para tareas específicas no están disponibles hasta que se recopilan los datos de detección de servicios por primera vez.

El módulo de administración de SMS 2003 usa las siguientes reglas de procesamiento de sucesos para iniciar secuencias de comandos de detección de servicios:

  • Clientes SMS\Clientes avanzados de SMS\Detección de servicios de SMS 2003
  • Servidores SMS\Servidores SMS comunes\Detección de servicios de SMS 2003

Las secuencias de comandos usan un proveedor con hora asincrónico para recopilar datos de detección de servicios una vez cada 24 horas de forma predeterminada. El proveedor también ejecuta:

  • La implementación del módulo de administración
  • Los cambios de configuración en el módulo de administración
  • El inicio y la detención del agente Operations Manager 2007

Supervisión de disponibilidad

En esta versión del módulo de administración de SMS, se proporcionan tres informes de disponibilidad: informe de disponibilidad de servidor de SMS 2003, informe de disponibilidad de punto de administración de SMS 2003 e informe de disponibilidad de servidor de sitio de SMS 2003.

El informe de disponibilidad de punto de administración es un informe de disponibilidad basado en el estado del componente. La disponibilidad de punto de administración se basa en un nuevo algoritmo, nuevas reglas y la secuencia de comandos de disponibilidad de punto de administración de supervisión de SMS 2003.

Todos los informes, incluidos los nuevos informes a los que hace referencia esta sección, se ejecutan en la base de datos OperationsManager, que permite especificar duraciones de informe mayores que la secuencia de comandos anterior, que creó los procedimientos almacenados sólo en la base de datos OperationsManager.

Para obtener más información acerca de la disponibilidad del servidor, vea Secuencias de comandos de SMS 2003 e Informes de SMS 2003.

Supervisión de estado

La supervisión de estado ofrece una representación gráfica del estado de todos los servidores o los servidores en el ámbito de grupos de equipos específicos. El módulo de administración admite esta función con una lista específica de grupos de equipos. Las funciones de servidor y los componentes se administran mediante la detección de servicios y el estado del componente se administra mediante un conjunto de reglas para la disponibilidad de servicio, los umbrales de rendimiento y el estado de punto de administración.

La tabla que aparece a continuación muestra los estados diferenciados por colores que se supervisan en los componentes de SMS.

Supervisión de estado de servidor SMS

Componente de SMS | Verde (Correcto) | Amarillo (Advertencia) | Rojo (Crítico)
Servidor de sitio (SS) | Sí | Sí | Sí
Punto de administración (MP) | Sí | Sí | Sí
Base de datos de sitio (DB) | Sí | Sí | Sí
Punto de distribución (DP) | Sí |  |
Punto de ubicación de servidor (SLP) | Sí |  | Sí
Remitente | Sí |  | Sí
Punto de notificación (RP) | Sí |  | Sí
Proveedor | Sí |  | Sí
Punto de acceso cliente (CAP) | Sí |  | Sí
Rendimiento | Sí | Sí | Sí
Nota
No hay reglas de supervisión que cambien el estado del componente de punto de distribución, por lo que si el componente está presente, se notifica sólo en el estado de color verde. Si no hay un componente de punto de distribución, el estado no se representa en la consola.

Supervisión de estado de cliente SMS

Componente de SMS | Verde (Correcto) | Amarillo (Advertencia) | Rojo (Crítico)
Servicio de cliente | Sí |  | Sí

Compatibilidad de supervisión sin agente

El módulo de administración de SMS 2003 admite la supervisión en equipos administrados sin agente, excepto para las siguientes características:

  • Supervisión de mensajes de estado de SMS críticos
  • Supervisión de estado de sistema de sitio
  • Topología

Las secuencias de comandos que admiten las características anteriores son:

  • Mensajes de estado de SMS de supervisión de SMS 2003
  • Generador de resumen de sistema de sitio de supervisión de SMS 2003
  • Topología de servidor de SMS 2003 detección

Estas secuencias de comandos deben ejecutarse localmente en el proveedor de SMS para obtener acceso al espacio de nombres de SMS. Si las secuencias de comandos no encuentran el espacio de nombres de SMS, se produce un suceso de error de secuencia de comandos.

Supervisión de umbral de rendimiento

Una reducción de los niveles de rendimiento genera retrasos y repercute en los contratos de nivel de servicio (SLA) del cliente por lo que respecta al tiempo, el rendimiento y la precisión de los datos. Es importante detectar y resolver problemas de rendimiento críticos en la infraestructura de SMS. La supervisión de umbral de rendimiento genera una alerta cuando:

  • La métrica de estado de equipo general relacionada con la CPU, el archivo de paginación y la memoria en sistemas de sitio de SMS superan determinados umbrales.
  • El número total de conexiones de usuario de Microsoft SQL Server™ supera un umbral.
  • El número total de archivos de SMS [como tareas de programador, solicitudes de envío, registros de disponibilidad de software, registros de datos de detección (DDR) y registros de inventario de software e inventario de hardware] supera determinados umbrales en las bandejas de entrada del servidor de sitio de SMS.
  • El número total de mensajes de SMS relacionados con mensajes de estado, DDR, inventario de software e inventario de hardware en las colas de mensajes de punto de administración de SMS supera determinados umbrales.

Supervisión de rendimiento

La supervisión de rendimiento permite ver tendencias en trabajos acumulados, tasas de procesamiento y números totales de objetos de SMS clave para ayudar a identificar y a resolver problemas activamente. La tendencia de rendimiento supervisa las siguientes tendencias gráficamente mediante las vistas y los informes de Operations Manager 2007:

  • Archivos de trabajos acumulados de las bandejas de entrada relacionados con tareas de programador, solicitudes de envío, registros de disponibilidad de software, DDR, inventario de hardware, inventario de software y mensajes de estado en servidores de sitio de SMS.
  • Tasas de procesamiento de tareas de programador, solicitudes de envío, registros de disponibilidad de software, DDR, inventario de hardware, inventario de software y mensajes de estado en servidores de sitio de SMS.
  • Número total de tareas de programador, solicitudes de envío, registros de disponibilidad de software, DDR, inventario de hardware, inventario de software y mensajes de estado en servidores de sitio de SMS.
  • Trabajos acumulados de mensajes relacionados con DDR, inventario de hardware, inventario de software, disponibilidad de software, mensajes de estado y otros objetos de SMS en colas de mensajes de servidor de punto de administración de SMS.
  • Tasas de procesamiento de DDR, inventario de hardware, inventario de software, disponibilidad de software, mensajes de estado y otros objetos de SMS en colas de mensajes de servidor de punto de administración de SMS.
  • Totales de DDR, inventario de hardware, inventario de software, relés y mensajes de estado en colas de mensajes de servidor de punto de administración de SMS.
  • Número total de conexiones de usuario de SQL Server en servidores de base de datos de sitio de SMS.
  • Métrica de estado de equipo relacionada con la CPU, el archivo de paginación y la memoria en sistemas de sitio de SMS.
  • Número total de subprocesos de SMS Executive en ejecución.
  • Tasa de solicitudes de extensión ISAPI en IIS.

Supervisión de mensajes de estado de SMS críticos

La infraestructura de SMS genera mensajes de estado de SMS. Es importante identificar los mensajes de estado de SMS críticos relacionados con el servidor y solucionarlos a tiempo. Estos mensajes normalmente indican problemas de disponibilidad, rendimiento, configuración y estado general de la infraestructura de SMS.

La supervisión de mensajes de estado de SMS críticos genera una alerta cuando se detectan mensajes de estado críticos para el estado de las funciones de sitio de SMS (como instalación de componentes, conectividad de base de datos y conectividad de sitio). La base de datos del sitio de SMS se comprueba cada media hora para ver si hay mensajes de estado de SMS críticos.

Supervisión de estado de sistema de sitio

SMS supervisa periódicamente el estado básico de sus sistemas de sitio mediante el generador de resumen de estado de sistema de sitio, que realiza un sondeo de los sistemas de sitio de SMS cada hora. Para aprovechar esta característica, este estado debe resolverse rápidamente para evitar la reducción de la funcionalidad de SMS. La supervisión de estado del sistema de sitio ofrece la posibilidad de supervisar y generar una alerta cuando se detecta un estado de generador de resumen de sistema de sitio de SMS crítico para el estado del sistema de sitio de SMS. Algunos de los mensajes de estado supervisados incluyen un sistema de sitio de SMS inactivo, un servidor con SQL Server que se está quedando sin espacio en la base de datos o en el registro, y sistemas de sitio de SMS que se están quedando sin espacio en el disco físico.

Supervisión de volcado ejecutivo

Los errores de servicio de SMS Executive repercuten en la disponibilidad de SMS y es importante saber cuándo se producen volcados e investigar las causas originales. Cuando se produce un error de servicio en SMS Executive, se crea un subdirectorio de registro de volcado en el directorio SMS\Logs\CrashDumps. La creación de este subdirectorio se supervisa y se genera una alerta para cada función de servidor de SMS que depende del servicio de SMS Executive.

La secuencia de comandos de volcado de SMS Executive de supervisión de SMS 2003 sólo notifica el volcado más reciente. Esto se aplica independientemente de cuándo se produjera el último volcado, desde la primera vez que se ejecutó la secuencia de comandos hasta cualquier ocasión en que se instaló y reinstaló SMS Executive.

Las reglas relacionadas se incluyen en el grupo de reglas Servidores de componentes de Microsoft SMS 2003 basados en SMS Executive:

  • Volcados de SMS 2003: supervisión de SMS Executive

Volcados de SMS 2003: supervisión de SMS Executive inicia la secuencia de comandos mediante el proveedor de sucesos programado SMS 2003 Schedule every 60 minutes synchronize at 00:10. En la página de propiedades Información de la regla se ofrece información de resumen.

  • Volcados de SMS 2003: supervisión de errores de secuencia de comandos de SMS

Volcados de SMS 2003: supervisión de errores de secuencia de comandos de SMS supervisa y genera alertas sobre sucesos de error de secuencias de comandos que se puedan producir. Sólo hay un suceso de error de secuencia de comandos (número 1102) que notifica todos los errores de secuencias de comandos. En la página de propiedades Información de la regla se ofrece información acerca de la solución de la alerta.

  • Volcados de SMS 2003: bloqueo de SMS Executive

Volcados de SMS 2003: bloqueo de SMS Executive supervisa y genera alertas sobre el suceso de volcado. En la página de propiedades Información de la regla se ofrece información acerca de la solución de la alerta.

Supervisión de trabajos acumulados

Los trabajos acumulados generan retrasos que repercuten en los contratos de nivel de servicio (SLA) del cliente por lo que respecta al tiempo, el rendimiento y la precisión de los datos. Es importante detectar y resolver con rapidez problemas de rendimiento críticos en la infraestructura de SMS. Se genera una alerta cuando un trabajo acumulado se encuentra por encima de un umbral durante un período de tiempo determinado en:

  • El número total de archivos de SMS como tareas de programador, solicitudes de envío, registros de disponibilidad de software, registros de datos de detección (DDR) y registros de inventario de software e inventario de hardware en las bandejas de entrada del servidor de sitio de SMS.
  • El número total de objetos de SMS [como tareas de programador, solicitudes de envío, registros de disponibilidad de software, registros de datos de detección (DDR) y registros de inventario de software e inventario de hardware] en las colas del servidor de sitio de SMS.

El número total de mensajes de SMS relacionados con mensajes de estado, DDR, inventario de software e inventario de hardware en las colas de mensajes de punto de administración de SMS.

Supervisión del estado general

La supervisión del estado general genera una alerta cuando la métrica de estado de un servidor SMS supera un umbral determinado durante un período de tiempo. La supervisión del estado general comprueba la siguiente métrica:

  • Tiempo de procesador en 95% en tres horas
    • Smsexec
    • Ccmexec
    • Total
  • Uso de archivo de paginación en 98% en tres horas

Supervisión de la administración de revisiones de SMS

Los administradores de SMS dependen de las características de administración de revisiones de SMS para mantener los equipos cliente y servidor de las empresas al día con las actualizaciones de seguridad más recientes. La supervisión de la administración de revisiones detecta cualquier error en el procesamiento y la configuración de la administración de revisiones de SMS. La supervisión de la administración de revisiones de SMS genera una alerta cuando:

  • Se produce un error en el proceso de sincronización de la administración de revisiones de SMS.
  • Se produce un error en el proceso de administración de revisiones para actualizar los puntos de distribución de SMS con las actualizaciones.

Supervisión de copias de seguridad del sitio de SMS

El conocimiento de cuándo se inició, completó o produjo un error la copia de seguridad de SMS 2003 puede ayudar a los administradores de SMS a realizar una auditoría de las actividades de copia de seguridad. Puede programar la copia de seguridad de SMS para que se ejecute periódicamente y copie los datos, las directivas y la configuración de SMS. Es importante supervisar los errores de este proceso de copia de seguridad y realizar las acciones correctivas necesarias. Incluso cuando la copia de seguridad de SMS se realiza correctamente, repercute en la disponibilidad del servicio porque este proceso detiene e inicia el administrador de componentes de sitio de SMS, SMS Executive y los servicios de supervisión de SQL de SMS. La supervisión de la copia de seguridad de SMS ayuda a hacer un seguimiento de los tiempos de inactividad conocidos en estos servicios porque las alertas sobre la detención de estos servicios se suprimen durante el proceso de copia de seguridad. Las siguientes reglas admiten la supervisión de la copia de seguridad de sitio de SMS:

  • Detención del servicio de SMS 2003: SMS_SITE_BACKUP
  • Inicio del servicio de SMS 2003: SMS_SITE_BACKUP
  • Estado de SMS 2003: la copia de seguridad del sitio se ha completado correctamente
  • Estado de SMS 2003: error de copia de seguridad del sitio

Información del producto para todas las alertas

Los administradores pueden hacer referencia a la información del producto de todas las alertas para facilitar la identificación específica de un problema y resolverlo. Para tener acceso a la información del producto, haga clic con el botón secundario en cualquier nombre de regla, haga clic en Propiedades y, a continuación, haga clic en la ficha Información de producto.

Grupos de equipos de todas las funciones de servidor y cliente de SMS 2003

La resolución de grupo de equipos ahora está establecida en funciones de cliente y servidor de SMS específicas. De este modo, los administradores obtienen un mayor control en la administración de replicación de reglas en agentes Operations Manager 2007. Los administradores pueden deshabilitar los grupos de equipos predeterminados o definir nuevos grupos de equipos basados en los grupos de equipos predeterminados y en los atributos de los equipos.

Supervisión expandida

Las reglas proporcionadas en el módulo de administración de SMS 2003 abarcan el servicio básico, la medición del rendimiento y la supervisión del umbral de rendimiento para SQL Server, IIS, Microsoft Windows® 2000 y los módulos de administración de sistemas operativos Windows Server® 2003. Puede habilitar la compatibilidad base en el módulo de administración de SMS 2003 para estos módulos de administración o puede mantener la configuración deshabilitada y habilitar las reglas correspondientes en otros módulos de administración.

  • Use el módulo de administración de SQL Server para expandir la supervisión de los servidores de base de datos del sitio de SMS y los puntos de administración que tienen dependencias de SQL Server.
  • Use el módulo de administración de IIS para supervisar IIS en puntos de notificación, puntos de administración y puntos de ubicación de servidor. El módulo de administración de IIS también puede supervisar puntos de distribución con BITS habilitado.
  • Use Microsoft Windows 2000 y el módulo de administración de sistema operativo base de Windows Server 2003 para supervisar componentes básicos de Windows, como la CPU, el disco y las estadísticas de memoria.

Hay otros módulos de administración, para los que el módulo de administración de SMS 2003 no proporciona reglas, que mejoran la supervisión de la infraestructura de SMS 2003.

  • Use el módulo de administración de equilibrio de carga de red de Windows si está usando el equilibrio de carga de red para admitir varios puntos de administración en la jerarquía de SMS por motivos de escalabilidad.
  • Use el módulo de administración de directorios de Windows Active Directory® para supervisar el estado de la infraestructura de Active Directory.

Si implementa varios módulos de administración en el entorno, es posible que reciba alertas redundantes basadas en reglas que existen en ambos módulos de administración. Si deshabilita las reglas de supervisión redundantes, es posible que afecte a la precisión de la vista de estado de los módulos de administración implementados. Debe estudiar detenidamente el equilibrio entre la recepción de alertas redundantes y el trabajo de supervisión de estado para cada módulo de administración que implemente. Según los módulos de administración adicionales que haya implementado, debe revisar estas reglas redundantes para identificar las reglas que quiera habilitar en el entorno. Después de instalar estos módulos de administración, confirme que están personalizados si es necesario, que están configurados adecuadamente y que tienen habilitadas las reglas apropiadas.

Estado de ejecución del programa de distribución de software

El cliente avanzado de SMS puede notificar errores de programa mediante el módulo de administración.

Los administradores pueden seleccionar la casilla de verificación Generate MOM alert if this program fails en la ficha MOM del cuadro de diálogo Program Properties.

Procedimiento

Para habilitar las alertas de Operations Manager 2007 si no se puede ejecutar un programa de SMS 2003, son necesarios los siguientes pasos:

Para habilitar las alertas de Operations Manager 2007 de un programa de SMS 2003

  1. En la consola de Systems Management Server, navegue a Systems Management Server / Site Database - <nombre del servidor de sitio> / Packages.

  2. En el panel de detalles, haga clic con el botón secundario en Program y seleccione Propiedades. El cuadro de diálogo de propiedades del programa se abre.

  3. Seleccione la ficha MOM.

  4. Haga clic en la casilla de verificación Generate MOM alert if this program fails to run. Haga clic en Aceptar.

Vea también

Conceptos

Implementación del módulo de administración de SMS 2003

Otros recursos

Referencia para el módulo de administración de Microsoft Systems Management Server 2003


Implementación del módulo de administración de SMS 2003

Antes de implementar el módulo de administración de Microsoft® Systems Management Server (SMS) 2003, revise la guía de implementación de Microsoft Operations Manager 2007 en la página web de Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259). Esta sección contiene instrucciones adicionales para implementar los módulos de administración de Operations Manager.

Para implementar el módulo de administración de SMS 2003, debe completar los siguientes procesos:

  • Implemente el agente Operations Manager 2007 en todos los equipos del componente de servidor SMS.
Nota
Si se necesita el modo de mantenimiento o la asignación de topologías de Operations Manager 2007, debe implementar SMS 2003 SP3 antes de importar el módulo de administración de SMS 2003 o instalar el agente Operations Manager 2007.

  • Importe el módulo de administración de SMS 2003 en un grupo de configuración de Operations Manager 2007.
  • Configure los servidores de proveedores de SMS y base de datos del sitio de SMS de tal modo que los agentes Operations Manager 2007 puedan establecer una conexión mediante un servidor proxy con otros equipos.
  • Complete las comprobaciones recomendadas y las tareas de prueba piloto.
  • Complete las tareas de ajuste recomendadas.

En esta sección

Implementación del agente Operations Manager 2007

Comprobación y realización de pruebas piloto del módulo de administración

Personalización del módulo de administración

Vea también

Conceptos

Escenarios de supervisión del módulo de administración

Otros recursos

Introducción al módulo de administración de Systems Management Server 2003
Realización de tareas de operaciones para el módulo de administración de SMS 2003
Solución de problemas del módulo de administración de SMS 2003
Referencia para el módulo de administración de Microsoft Systems Management Server 2003


Implementación del agente Operations Manager 2007

El agente Operations Manager se ejecuta en cada uno de los equipos supervisados por Operations Manager. Para ver los grupos de equipos supervisados por el módulo de administración de SMS 2003, vea la sección Grupos de equipos para SMS 2003 en esta guía. El agente Operations Manager 2007 recopila los datos de supervisión en el equipo administrado, aplica las reglas a los datos recopilados y, a continuación, envía los datos obtenidos a Data Consolidator Agent Manager (DCAM). El servicio Operations Manager 2007 (HealthService.exe), el host de Operations Manager 2007 (MonitoringHost.exe) y la cuenta de acción del agente proporcionan la funcionalidad de supervisión en un equipo agente.

El agente Operations Manager 2007 puede implementarse mediante el asistente para la instalación de Operations Manager 2007 o la distribución de software de SMS. Para obtener información detallada acerca de cómo implementar el agente Operations Manager 2007 y usar el asistente para la instalación de Operations Manager 2007, consulte el capítulo referente a la detección de equipos y a la implementación de agentes MOM en la guía de implementación de Microsoft Operations Manager 2007. Para obtener más información, visite la página web de Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Nota
Se recomienda ejecutar el agente Operations Manager 2007 en equipos de proveedor de SMS con la cuenta LocalSystem o una cuenta con suficientes derechos de acceso al directorio root, root\cimv2, root\sms, así como a la clave y subclaves del registro de SMS de espacios de nombre de SMS 2003 WMI.

Para determinar si la supervisión sin agente se puede usar en su entorno, consulte la sección de compatibilidad para la supervisión sin agente en Escenarios de supervisión del módulo de administración.

Configuración de equipos de agente para la ejecución en escenarios con pocos privilegios

El servicio Operations Manager 2007 (HealthService.exe), el host de Operations Manager 2007 (MonitoringHost.exe) y la cuenta de acción del agente proporcionan la funcionalidad de supervisión en un equipo agente. En Microsoft Windows® 2000, la cuenta de acción debe pertenecer al grupo de administradores locales. En determinadas circunstancias, una cuenta con pocos privilegios para la cuenta de acción del agente se puede usar en Microsoft Windows™ 2003. Sin embargo, la configuración de la cuenta de acción y el contexto de usuario, en que el proceso de servicio Operations Manager 2007 y host de Operations Manager 2007 Host se ejecuta con los derechos y permisos necesarios para ejecutar las características del módulo de administración de SMS 2003, requiere la realización de muchas tareas de configuración manual en el equipo del agente. En Microsoft Windows Server™ 2003, la cuenta de acción del agente debe tener como mínimo los siguientes derechos y permisos de usuario:

  • Miembro del grupo de usuarios locales
  • Acceso a los registros de sucesos de Windows
  • Permiso Administrar registro de seguridad y auditoría (SeSecurityPrivilege)
  • Permiso Generar auditorías de seguridad (SeAuditPrivilege)
  • Permiso Permitir el inicio de sesión local (SeInteractiveLogonRight)

En un escenario con pocos privilegios, el módulo de administración de SMS 2003 requiere que la cuenta usada para la cuenta de acción del agente tenga derechos y permisos adicionales. En la siguiente tabla se describen los derechos de acceso que deben configurarse manualmente.

Tipos de acceso necesarios para el módulo de administración de SMS 2003

Recurso | Tipo de acceso | Instrucciones
Registro de sucesos de Windows | Lectura | La cuenta de acción debe tener asignado el privilegio Administrar registro de seguridad y auditoría mediante la directiva local o global.
Claves de registro de SMS | Lectura | HKLM\Software\Microsoft\SMS Agregue la cuenta de acción a las propiedades del registro y conceda acceso de lectura, el cual heredarán todas las subclaves.
Claves de registro de servicios Win32 | Lectura | HKLM\System\CurrentControlSet\Services Agregue la cuenta de acción al grupo de usuarios locales.
Archivos temporales generados por secuencia de comandos | Lectura y escritura | %Windir%\Temp Agregue la cuenta de acción al grupo de usuarios locales. .
Archivos de registro generados por secuencia de comandos | Lectura y escritura | %Windir%\Microsoft Operations Manager Agregue la cuenta de acción a las propiedades de la carpeta.
Archivos de registro de SMS | Lectura | \SMS\Logs Agregue la cuenta de acción a las propiedades de la carpeta.
Espacios de nombres de WMI | Lectura | root y root\cimv2 No es necesario realizar ninguna acción.
Espacios de nombres de SMS WMI | Lectura | No es necesario realizar ninguna acción.
Clases SMS WMI | Lectura | SMS_Site SMS_R_System SMS_SystemResourceList SMS_SiteSystemSummarizer Agregue la cuenta de acción a la clase para todas las instancias.
Derechos de inicio de sesión de seguridad para la instancia predeterminada | Conceder acceso | Para la instancia predeterminada de un equipo de SQL Server administrado, la cuenta de acción debe tener derechos Conceder acceso para los inicios de sesión de seguridad. En el Administrador corporativo de SQL Server, agregue la cuenta de acción al siguiente nodo: instancename\Security\Logins.
Acceso a la base de datos maestra en la instancia predeterminada (necesario para identificar la base de datos del sitio de SMS) | Permitir | Para la instancia predeterminada de un equipo de SQL Server administrado, la cuenta de acción debe tener derechos Permitir para obtener acceso a la base de datos maestra. En el Administrador corporativo de SQL Server, agregue la cuenta de acción al siguiente nodo: instancename\Databases\Master\Users. Mantenga todos los permisos predeterminados asociados a este nuevo usuario.
Acceso a la base de datos del sitio de SMS en la instancia predeterminada | Permitir | Para la instancia predeterminada de un equipo de SQL Server administrado, la cuenta de acción debe tener derechos Permitir para la base de datos del sitio de SMS. En el Administrador corporativo de SQL Server, agregue la cuenta de acción al siguiente nodo: instancename\Databases\<SMS site>\Users. Mantenga todos los permisos predeterminados asociados a este nuevo usuario.

Vea también

Conceptos

Comprobación y realización de pruebas piloto del módulo de administración
Personalización del módulo de administración
Problemas conocidos de SMS 2003

Otros recursos

Solución de problemas del módulo de administración de SMS 2003


Comprobación y realización de pruebas piloto del módulo de administración

Además de las recomendaciones generales que se explican en la guía de implementación de Microsoft Operations Manager 2007 para probar los módulos de administración y realizar pruebas piloto de los mismos, en este apartado se enumeran tareas de prueba adecuadas para el módulo de administración de SMS 2003. Para obtener más información, vea la página web de Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Tareas de prueba

  • Compruebe que los grupos de equipos con SMS 2003 estén rellenados con equipos con SMS 2003.
  • Después de habilitar las reglas pertinentes, asegúrese de que las vistas e informes de Operations Manager 2007 funcionen correctamente. Entre las vistas mencionadas se encuentran las relativas a las velocidades de procesamiento de SMS y a los trabajos acumulados de SMS.
  • De forma predeterminada, ciertas reglas relacionadas con otros módulos de administración, como los de IIS y SQL Server, están deshabilitadas en el módulo de administración de SMS 2003. En función de los módulos de administración adicionales que haya implementado, debería revisar las reglas deshabilitadas para buscar las que desee habilitar en su entorno.
  • De forma predeterminada, todas las reglas de medición de rendimiento se deshabilitan para minimizar el impacto en la memoria, los recursos de red y la CPU del agente. Es posible habilitar estas reglas para obtener una mayor supervisión del agente.
  • Algunas secuencias de comandos de SMS que se ejecutan en un equipo con proveedor de SMS, un servidor de bases de datos del sitio de SMS o que tienen acceso a una base de datos del sitio de SMS no se ejecutan en modo sin agente. Compruebe que todos los equipos de los grupos de equipos del proveedor de Microsoft SMS 2003 y el servidor de bases de datos de sitios de Microsoft SMS estén configurados como equipos administrados con agente. Además, dado que es posible que algunas de estas secuencias de comandos usen eventos de proxy, debe comprobar que estos agentes están configurados para habilitar las conexiones proxy.

Tareas de prueba piloto

  • Compruebe que la implementación del módulo de administración de SMS 2003 o el proceso de actualización desde la versión anterior se hayan completado correctamente.
  • Compruebe y edite los umbrales personalizados de su entorno mediante la vista Health Monitor del umbral de rendimiento.
  • Habilite las reglas de rendimiento por fases para valorar el impacto que tienen en el rendimiento de Operations Manager 2007.
  • Compruebe que los grupos de equipos con SMS 2003 estén rellenados con equipos con SMS 2003.
  • Después de habilitar las reglas pertinentes, asegúrese de que las vistas e informes de Operations Manager 2007 funcionen correctamente. Entre las vistas mencionadas se encuentran las relativas a las velocidades de procesamiento de SMS, a los totales de procesamiento y a los trabajos acumulados de SMS.
  • De forma predeterminada, algunas reglas relacionadas con otros módulos de administración están deshabilitadas. En función de los módulos de administración adicionales que haya implementado, debería revisar las reglas deshabilitadas para buscar las que desee habilitar en su entorno.
  • De forma predeterminada, algunas reglas de rendimiento se deshabilitan para minimizar el impacto en la memoria, los recursos de red y la CPU del agente. Es posible habilitar estas reglas para obtener una mayor supervisión del agente.
  • Compruebe que no se generen sucesos basados en la ejecución de secuencias de comandos de SMS 2003. Estos suelen indicar problemas con los permisos de acceso a la secuencia de comandos.
  • Compruebe que el tamaño del DCAM y el SQL Server sea suficiente para la carga de producción.
  • Compruebe los procesos operativos y los requisitos del personal.
  • Compruebe que la paginación y la notificación por correo electrónico funcione correctamente.
  • Compruebe que los permisos que esté usando Operations Manager 2007 sean suficientes para un funcionamiento correcto, sin ser excesivos.
  • Si no se ha especificado que el agente Operations Manager 2007 se ejecute en la cuenta del sistema local, asegúrese de que se cumplan los derechos de seguridad mínimos. Para obtener más información, vea la sección de configuración de equipos agentes para la ejecución con pocos privilegios del apartado Implementación del agente Operations Manager 2007 de esta guía.
  • Compruebe que las funciones del servidor SMS y cliente SMS aparezcan en la vista Estado. Haga clic en un equipo que aloje cada una de estas funciones y compruebe que los componentes aparezcan en el panel de instancias.
  • Haga clic en una tarea para comprobar que funcionan las tareas de la consola de administrador de SMS. Si la tarea no se ejecuta, compruebe que se ha instalado la consola de administrador de SMS 2003 SP2 y que el usuario que había iniciado la sesión la haya cerrado y, después de la instalación de la consola, haya iniciado sesión de nuevo.
  • En la vista Estado, haga clic en un servidor de SMS y un cliente de SMS para comprobar que en la página Roles aparecen las funciones y los datos de propiedad correspondientes.
  • En el panel Supervisión, navegue a Microsoft Systems Management Server (SMS) 2003 y, a continuación, haga clic en SMS 2003 Site Hierarchy Diagram. Compruebe que aparezcan todos los sistemas de sitio que tengan instalado el agente Operations Manager 2007 localmente en su proveedor de SMS. Si no aparece ningún sistema del sitio, observe la consola de administrador de SMS para comprobar si el sitio ha detectado el sistema de sitio y éste aparece en la colección All Systems.

Después de llevar a cabo la prueba piloto, exporte el módulo de administración de SMS 2003 para hacer una copia de seguridad de los cambios realizados en el mismo.

Vea también

Conceptos

Personalización del módulo de administración
Implementación del agente Operations Manager 2007
Problemas conocidos de SMS 2003

Otros recursos

Solución de problemas del módulo de administración de SMS 2003


Personalización del módulo de administración

Para conseguir una supervisión óptima, es posible personalizar el módulo de administración de SMS 2003 en función de las necesidades comerciales de su empresa. Si las reglas existentes no responden a las necesidades de la empresa, modifíquelas y cree otras nuevas.

Nota Haga siempre una copia de seguridad del módulo de administración de SMS 2003 antes de hacer cambios. El asistente para exportar módulos de administración de Operations Manager 2007 permite hacer copias de seguridad de paquetes de administración que no estén sellados.

Las personalizaciones posibles son, entre otras, las siguientes:

  • Habilitación y deshabilitación de reglas mediante reemplazos.
  • Creación de nuevas reglas.
  • Modificación de criterios de alerta, gravedad de alertas y supresión de alertas.
  • Configuración de umbrales personalizados para las reglas. Todas las reglas de los umbrales de rendimiento se pueden configurar. Si el umbral predeterminado no es óptimo, es posible que reciba alertas innecesarias o que no reciba ninguna porque el umbral es demasiado alto para su entorno.
  • Configuración de umbral de reglas de sucesos de supervisión de la bandeja de entrada e intervalos de sondeo mediante reemplazos o, en el caso de los valores de umbrales, mediante la edición de la vista en XML.
  • Agregación de nuevas reglas de sucesos de supervisión de la bandeja de entrada. Para agregar una nueva regla de supervisión de la bandeja de entrada, cree una nueva regla en el módulo de administración predeterminado, cree reemplazos para los parámetros de entrada de secuencias de comandos (FileCountThreshold y InboxDirectoryName) y realice la programación.
  • Configuración de intervalos de sondeo para la medición del rendimiento mediante reemplazos.
  • Agregación de contenido a la información de la compañía.
  • Personalización de respuestas a alertas cambiando o agregando nuevas respuestas a reglas o agregando reglas de procesamiento de alertas para dichas alertas.
  • Si se habilitan reglas de medición de rendimiento en el agente, el servidor con Operations Manager 2007 y la base de datos, se genera una gran cantidad de datos y es posible que se produzcan problemas de rendimiento. Las reglas de medición de rendimiento están deshabilitadas de forma predeterminada para que decida si es aceptable o no un posible impacto en el rendimiento. Revise las reglas de rendimiento y habilite estas reglas por lotes pequeños, de forma que pueda evaluar el impacto que tienen estas reglas en el rendimiento de Operations Manager 2007 (por ejemplo, en el tamaño de la base de datos).
  • Configuración de parámetros para reglas de sucesos de supervisión de la bandeja de entrada y reglas relacionadas. Cree un reemplazo para modificar las dos secuencias de comandos FileCountThreshold y InboxDirectoryName,.
  • Revisión de reglas para comprobar si se aplican a su entorno. De forma predeterminada, algunas reglas relacionadas con otros módulos de administración están deshabilitadas. En función de los módulos de administración adicionales que haya implementado, debería revisar las reglas deshabilitadas para buscar las que desee habilitar en su entorno.

Para obtener más información sobre las personalizaciones de los módulos de administración y cómo exportar las mismas, vea los temas acerca de los módulos de administración de Operations Manager 2007 y acerca de cómo exportar personalizaciones de módulos de administración en la ayuda de Operations Manager 2007.

Supervisión de la bandeja de entrada

El asistente de exportación de Operations Manager 2007 permite guardar los cambios en el módulo de administración predeterminado antes de realizar cambios adicionales.

Configuración de reglas de supervisión de la bandeja de entrada

Para implementar estas reglas en servidores de sitio centrales, primarios y secundarios, cree nuevas reglas en el módulo de administración basadas en reglas de los servidores comunes del sitio de SMS. A continuación, estas reglas se pueden asignar al grupo de reglas de procesamiento correspondiente del servidor de sitio: modifique el umbral y habilite la regla.

  • Bandeja de entrada de SMS 2003: bandeja de entrada del monitor
  • Bandeja de entrada de SMS 2003: Monitor inbox script error
  • Bandeja de entrada de SMS 2003: umbral superado

La regla de procesamiento de sucesos bandeja de entrada de SMS 2003: umbral superado supervisa sucesos de la secuencia de comandos SMS 2003: Monitor Inbox script error. Se genera una sola alerta para cada bandeja de entrada que supere el umbral especificado.

El umbral predeterminado para esta secuencia de comandos es de 10.000 archivos en una bandeja de entrada. Se puede crear un reemplazo de este valor en el módulo de administración predeterminado para los parámetros de esta secuencia de comandos o cualquier otra. Si se supera el umbral, se provoca un suceso de "umbral superado". Para modificar la configuración del umbral, calcule la carga diaria que se espera en los servidores para cada proceso que funcione correctamente y, a continuación, sume un porcentaje razonable de almacenamiento en búfer. Las reglas de supervisión de la bandeja de entrada se ejecutan una vez al día de forma predeterminada, en incrementos de 15 minutos a partir de la 1:00. Para minimizar el impacto en el rendimiento, se recomienda mantener o ajustar este intervalo para minimizar la posibilidad de que se superpongan ejecuciones de secuencias de comandos entre reglas de supervisión de la bandeja de entrada.

En la siguiente tabla se enumeran las reglas de supervisión de la bandeja de entrada, los umbrales predeterminados y las bandejas de entrada que se supervisan en el proveedor de SMS Executive.

Supervisión de la bandeja de entrada de SMS Executive

Nombre de la regla de supervisión de la bandeja de entrada | Umbral predeterminado | Nombre de la bandeja de entrada
Bandeja de entrada de SMS 2003: Monitor inbox script error | N/D | N/D
Bandeja de entrada de SMS 2003: umbral superado | N/D | N/D
Bandeja de entrada de SMS 2003: Monitor auth\dataldr.box | 10000 | Inboxes\auth\dataldr.box
Bandeja de entrada de SMS 2003: Monitor auth\ddm.box | 10000 | Inboxes\auth\ddm.box
Bandeja de entrada de SMS 2003: Monitor auth\sinv.box | 10000 | Inboxes\auth\sinv.box
Bandeja de entrada de SMS 2003: Monitor compsumm.box\repl | 10000 | Inboxes\ compsumm.box\repl
Bandeja de entrada de SMS 2003: Monitor dataldr.box | 10000 | Inboxes\ dataldr.box
Bandeja de entrada de SMS 2003: Monitor ddm.box | 10000 | Inboxes\ ddm.box
Bandeja de entrada de SMS 2003: Monitor despoolr.box\receive | 10000 | Inboxes\despoolr.box\receive
Bandeja de entrada de SMS 2003: Monitor offermgr.box\INCOMING | 10000 | Inboxes\offermgr.box\INCOMING
Bandeja de entrada de SMS 2003: Monitor offersum.box\repl | 10000 | Inboxes\ offersum.box\repl
Bandeja de entrada de SMS 2003: Monitor replmgr.box\incoming | 10000 | Inboxes\replmgr.box\incoming
Bandeja de entrada de SMS 2003: Monitor schedule.box\outboxes\LAN | 10000 | Inboxes\ schedule.box\outboxes\LAN
Bandeja de entrada de SMS 2003: Monitor statmgr.box\statmsgs | 10000 | Inboxes\statmgr.box\statmsgs
Bandeja de entrada de SMS 2003: Monitor swmproc.box\usage | 10000 | Inboxes\swmproc.box\usage

Procedimiento para reemplazar las reglas de sucesos de supervisión de la bandeja de entrada

Antes de reemplazar una regla de suceso de supervisión de la bandeja de entrada, el servidor de sitio de Operations Manager 2007 debe detectar los objetos del servidor de sitio de SMS 2003 del tipo Microsoft SMS 2003 Site Servers.

Para reemplazar las reglas de sucesos de supervisión de la bandeja de entrada

  1. En la Consola del operador de Operations Manager 2007, seleccione el botón Crear.

  2. Navegue a Crear / Objetos del módulo de administración / Reglas.

  3. Ámbito para los servidores de sitio de Microsoft SMS 2003.

  4. Haga clic con el botón secundario en una regla de sucesos de supervisión de la bandeja de entrada de SMS 2003 adecuada, como Bandeja de entrada de SMS 2003: Moinitor schedule box\requests, seleccione Invalidaciones, seleccione Override the Rule y, a continuación, haga clic en Para todos los objetos de tipo: Microsoft SMS 2003 Site Servers.

  5. En Propiedades de invalidación, active la casilla de verificación Habilitado y establezca Invalidar configuración en True.

  6. En Propiedades de invalidación, active la casilla de verificación FileCountThreshold y establezca Invalidar configuración en el valor de umbral deseado.

  7. Haga clic en Aceptar. Haga clic en Aceptar. Los valores de umbral modificados se distribuyen a los servidores.

Procedimiento para editar la supervisión de umbral de contador de rendimiento

Para editar la supervisión de umbral de contador de rendimiento, siga estos pasos:

Para editar la supervisión de umbral de contador de rendimiento

  1. En la Consola del operador de Operations Manager 2007, seleccione el botón Crear.

  2. Navegue a Crear / Objetos del módulo de administración / Monitores.

  3. Cambie el ámbito al servidor de SMS.

  4. Navegue a SMS Server / Entity Health / MOM 2005 Computer Role Health y, a continuación, seleccione la función del equipo correspondiente, como SS para el servidor de sitio.

  5. Haga doble clic en la regla de supervisión del umbral de rendimiento que desee editar. Se abre el cuadro de diálogo Performance Threshold Properties.

  6. Seleccione la ficha Configuración.

  7. Haga clic en Editar…. Se abre el cuadro de diálogo Configuración xml.

  8. En el texto XML, edite el valor de umbral que desee modificar.

    • Especifique <ValueExpression>, anidado en <CriticalErrorExpression>, para cambiar el umbral de los errores críticos.
    • Especifique <ValueExpression>, anidado en <WarningExpression>, para cambiar el umbral de las advertencias.

  9. Haga clic en Aceptar. Haga clic en Aceptar. Los valores de umbral modificados se distribuyen a los servidores.

Vea también

Conceptos

Comprobación y realización de pruebas piloto del módulo de administración
Configuración de SMS compatible
Escenarios de supervisión del módulo de administración

Otros recursos

Solución de problemas del módulo de administración de SMS 2003
Referencia para el módulo de administración de Microsoft Systems Management Server 2003


Realización de tareas de operaciones para el módulo de administración de SMS 2003

Se recomienda revisar y resolver puntualmente todas las alertas para identificar las que sean importantes o potencialmente críticas. Además, es necesario realizar otras tareas regularmente, según el entorno. Muchos problemas importantes no generan alertas, pero necesitan una atención periódica. El módulo de administración de Microsoft® Systems Management Server (SMS) 2003 dispone de vistas e informes que muestran datos en el transcurso del tiempo y presentan patrones que indican problemas. Revise las vistas y los informes para resolver los problemas antes de que generen alertas.

Debe realizar las tareas diarias, semanales y mensuales que se especifican en esta sección, pero ajuste la frecuencia de las tareas para que satisfagan las necesidades de su entorno concreto.

En esta sección

Tareas diarias de SMS 2003

Tareas semanales de SMS 2003

Tareas mensuales de SMS 2003

Tareas de la consola de administrador de SMS 2003

Vea también

Conceptos

Escenarios de supervisión del módulo de administración
Implementación del módulo de administración de SMS 2003

Otros recursos

Introducción al módulo de administración de Systems Management Server 2003
Realización de tareas de operaciones para el módulo de administración de SMS 2003
Solución de problemas del módulo de administración de SMS 2003
Referencia para el módulo de administración de Microsoft Systems Management Server 2003


Tareas diarias de SMS 2003

Se recomienda realizar las siguientes tareas diariamente:

  • Revise todas las alertas abiertas.
  • Revise la pertenencia a grupos de equipos.
  • Compruebe que todos los agentes Operations Manager 2007 se estén comunicando con el servidor de Operations Manager 2007.
  • Revise los trabajos acumulados de rendimiento.
  • Revise las tasas de procesamiento de rendimiento.
  • Revise el rendimiento del agente y el servidor de Operations Manager 2007.
  • Revise la pertenencia a grupos de notificación o los grupos de notificación de reglas de procesamiento de sucesos.
  • Revise las copias de seguridad del sitio de SMS 2003.
  • Revise los sucesos (opcional).

Revisión de todas las alertas abiertas

En el módulo de administración de SMS 2003, las alertas se muestran en el siguiente formato de descripción de alertas:

$Computer$ <Rule Name>

$Description$

Event details

Revise todas las alertas de Operations Manager 2007 para asegurarse de que se procesan a tiempo. Puede usar cualquiera de los siguientes métodos para revisar alertas abiertas:

  • En la Consola del operador, haga clic en el botón Supervisión, expanda Microsoft Systems Management Server (SMS) 2003 y haga clic en Alertas.
  • En la Consola del operador, haga clic en el botón Supervisión, expanda Microsoft Systems Management Server (SMS) 2003 y haga clic en General. Seleccione Alerts that are New in the last 72 hours.
  • Un equipo o un grupo de equipos puede ver las alertas al hacer clic en Computer and Groups. Para ver un resumen por gravedad de las alertas, haga clic con el botón secundario en el grupo de equipos de SMS 2003 que quiera examinar, seleccione Vista y, a continuación, haga clic en Alertas.
  • Las alertas se pueden ver mediante la vista Estado. La vista Estado muestra una lista de equipos y la alerta de mayor gravedad. Haga doble clic en cualquier equipo para obtener una lista de las alertas actuales.
  • Las alertas se pueden ver mediante la vista Diagrama. La vista Diagrama de la jerarquía de SMS 2003 muestra una representación gráfica de la jerarquía de SMS 2003. Cada equipo tiene una nota de estado que indica la alerta de mayor gravedad. Haga doble clic en cualquier equipo para obtener una lista de las alertas actuales.

Se recomienda revisar todas las alertas nuevas en el orden siguiente:

  1. Alertas de servicio principales de SMS 2003
  2. Alertas de servicio dependientes de SMS 2003
  3. Alertas basadas en el generador de resumen de estado del sistema de sitio de SMS 2003
  4. Alertas de estado de punto de administración de SMS 2003
  5. Alertas basadas en los mensajes de estado de SMS 2003
  6. Alertas de componentes de SMS 2003
  7. Alertas de trabajos acumulados de SMS 2003
  8. Alertas de supervisión de la bandeja de entrada de SMS 2003
  9. Alertas de error de copia de seguridad del sitio de SMS 2003
  10. Alertas de error de programa de SMS 2003

Revisión de la pertenencia a grupos de equipos

La revisión de la pertenencia a grupos de equipos se puede comprobar mediante Operations Manager 2007.

  • En la Consola del operador, haga clic en el botón Crear, seleccione Grupos y, a continuación, haga clic con el botón secundario en el grupo de equipos correspondiente de SMS 2003. Compruebe que cada grupo de equipos mostrado contenga los equipos correctos.

Comprobación de que los agentes se comunican con el servidor de Operations Manager 2007

Un error de comunicación entre el agente y la infraestructura de supervisión impide que reciba alertas. Compruebe que el agente y el servidor con Operations Manager 2007 se comunican mediante la ejecución de los informes de disponibilidad. Para obtener más información, vea el tema acerca de la creación de un informe de disponibilidad en Operations Manager 2007 en la Ayuda de Operations Manager 2007.

Revisión de los trabajos acumulados de rendimiento y las tasas de procesamiento de rendimiento

Los trabajos acumulados de rendimiento y las tasas de procesamiento de rendimiento son muy útiles para detectar tendencias diarias y comprender qué sucede en la jerarquía de SMS. Los trabajos acumulados de rendimiento y las tasas de procesamiento de rendimiento se pueden ver en Operations Manager 2007.

Para revisar los trabajos acumulados de rendimiento

Para revisar los trabajos acumulados de rendimiento, realice los siguientes pasos:

Para revisar los trabajos acumulados de rendimiento

  1. En la Consola del operador, haga clic en el botón Supervisión y, a continuación, expanda Microsoft Systems Management Server (SMS) 2003.

  2. Expanda Rendimiento y, a continuación, expanda Backlogs. A continuación, haga clic en la subcarpeta de componente apropiada. Use la opción de contador para reducir los datos mostrados, el número de equipos o para seleccionar sólo los equipos de interés.

Revisión de las tasas de procesamiento de rendimiento

Para revisar las tasas de procesamiento de rendimiento, realice los siguientes pasos:

Para revisar las tasas de procesamiento de rendimiento

  1. En la Consola del operador, haga clic en el botón Supervisión y, a continuación, expanda Microsoft Systems Management Server (SMS) 2003.

  2. Expanda Rendimiento y, a continuación, expanda Backlogs. A continuación, haga clic en la subcarpeta de componente apropiada. Use la opción de contador para reducir los datos mostrados, el número de equipos o para seleccionar sólo los equipos de interés.

Supervisión de copias de seguridad del sitio de SMS 2003

Debe habilitar la tarea de mantenimiento de copias de seguridad del sitio de SMS y programar copias de seguridad según sea necesario en el entorno de su empresa. Cuando se inicia el servicio de copias de seguridad del sitio de SMS, primero se detienen todos los servicios de SMS, incluidos SMS_EXECUTIVE, SMS_SQL_MONITOR y SMS_SITE_COMPONENT_MANAGER. El proceso de copia de seguridad del sitio de SMS no admite copias de seguridad en tiempo de ejecución durante:

  • La copia de partes de la carpeta de instalación de SMS en la ruta de exportación de la copia de seguridad.
  • La copia de seguridad de los diferentes valores de registro de SMS.
  • La copia de seguridad de la base de datos del sitio de SMS en un servidor con Microsoft SQL Server™.

Cuando se completa la copia de seguridad, el servicio de copia de seguridad del sitio de SMS reinicia los servicios de SMS. Estas detenciones e inicios son normales durante el proceso de copia de seguridad y no indican ningún error crítico. Las alertas que se esperan de estas detenciones de servicios se suprimen durante la copia de seguridad del sitio de SMS. Puede correlacionar estas detenciones y estos inicios de servicio, además de las detenciones y los inicios de la copia de seguridad del sitio de SMS. Para ello, debe habilitar las siguientes reglas. Estas reglas generan alertas informativas cuando el servicio de copia de seguridad del sitio de SMS se inicia o se detiene:

  • Detención del servicio de SMS 2003: SMS_SITE_BACKUP
  • Inicio del servicio de SMS 2003: SMS_SITE_BACKUP

Las siguientes alertas se generan cuando el servicio de copia de seguridad del sitio de SMS no se inicia o se detiene inesperadamente:

  • Error del servicio de SMS 2003: SMS_SITE_BACKUP finalizó inesperadamente
  • Error del servicio de SMS 2003: inicio de SMS_SITE_BACKUP detenido
  • Error del servicio de SMS 2003: error de inicio de SMS_SITE_BACKUP
  • Error del servicio de SMS 2003: SMS_SITE_BACKUP no pudo iniciar sesión
  • Error del servicio de SMS 2003: SMS_SITE_BACKUP depende de otro servicio que no se pudo iniciar o que no existe

Si ve una alerta que indica que el servicio terminó inesperadamente, compruebe que se han reiniciado todos los servicios detenidos. Es posible que el servicio de copia de seguridad del sitio de SMS haya terminado antes de reiniciar estos servicios.

Las siguientes alertas de mensaje de estado se generan para mostrar si el proceso de copia de seguridad se ha realizado correctamente o si se ha producido un error.

  • Estado de SMS 2003: la copia de seguridad del sitio se ha completado correctamente
  • Estado de SMS 2003: Error de copia de seguridad del sitio

Es posible que la copia de seguridad no se pudiera realizar por problemas de acceso, falta de espacio en disco, error al iniciar o detener determinados servicios, o errores en operaciones del servidor de SQL.

Revisión de sucesos

Debe revisar los sucesos regularmente porque indican errores no críticos y proporcionan información acerca del funcionamiento del agente Operations Manager 2007.

Para revisar sucesos

Para revisar sucesos, realice los siguientes pasos:

Para revisar sucesos

  1. En la Consola del operador, haga clic en el botón Supervisión.

  2. Expanda Microsoft Systems Management Server (SMS) 2003 y haga clic en Eventos.

Vea también

Conceptos

Tareas semanales de SMS 2003
Tareas mensuales de SMS 2003
Tareas de la consola de administrador de SMS 2003

Otros recursos

Realización de tareas de operaciones para el módulo de administración de SMS 2003
Solución de problemas del módulo de administración de SMS 2003
Referencia para el módulo de administración de Microsoft Systems Management Server 2003


Tareas semanales de SMS 2003

Además de las tareas que realiza diariamente, realice las siguientes tareas semanalmente:

  • Revise los informes. Para obtener una lista de los informes que se incluyen en el módulo de administración de SMS 2003, vea la sección Informes de SMS 2003 en esta guía.
  • Revise las alertas, los sucesos y el rendimiento de la semana pasada para buscar posibles problemas y tendencias.
  • Si es necesario, ajuste las opciones de configuración de Operations Manager 2007 como, por ejemplo, el intervalo entre latidos del agente Operations Manager 2007, el intervalo de comprobación de estado de la supervisión de servicios, el intervalo de detección de latidos de Agent Manager, los intervalos de detección y los parámetros de limpieza de base de datos.
  • Revise el historial de copia de seguridad de los sitios de SMS.
  • Revise el historial de copia de seguridad del grupo de configuración de Operations Manager 2007 para SMS 2003.
  • Revise la base de datos y el registro de SQL Server.
  • Ejecute los informes de disponibilidad de SMS 2003 para obtener la disponibilidad de los servidores SMS y sus componentes.
  • Compruebe la jerarquía de SMS mediante el diagrama de jerarquías de SMS 2003.

Vea también

Conceptos

Tareas diarias de SMS 2003
Tareas mensuales de SMS 2003
Tareas de la consola de administrador de SMS 2003

Otros recursos

Realización de tareas de operaciones para el módulo de administración de SMS 2003
Solución de problemas del módulo de administración de SMS 2003
Referencia para el módulo de administración de Microsoft Systems Management Server 2003


Tareas mensuales de SMS 2003

Además de las tareas que realiza diaria y semanalmente, revise los datos de las siguientes categorías mensualmente.

Alertas y sucesos más comunes

  • Alertas más comunes
  • Sucesos más comunes
  • Alertas y sucesos más comunes por grupo de reglas
  • Alertas y sucesos más comunes por componente de SMS 2003
  • Alertas y sucesos más comunes por característica de SMS 2003

Desarrolle un plan de acción para reducir estos números.

Supervisión de trabajos acumulados de SMS

  • Consulte los informes relacionados con las tendencias de trabajos acumulados en varios sistemas de sitio.

Tendencias de trabajos acumulados de SMS

  • Revise los informes relacionados con trabajos acumulados para asegurarse de que no hay ninguna tendencia al alza a largo plazo del número de trabajos acumulados o un nivel inaceptable de trabajos acumulados que afecten a los contratos de nivel de servicio (SLA) de un sistema de sitio de SMS.

Tendencias de rendimiento de SMS: totales y tasas de procesamiento

  • Registros de datos de detección
  • Inventario de hardware
  • Inventario de software
  • Disponibilidad de software
  • Mensajes de estado

Rendimiento general del sistema

  • Uso del disco
  • Uso de memoria
  • Uso del procesador

Disponibilidad de servicio de SMS

  • SMS_EXECUTIVE
  • Servicio de host de agente de SMS
  • Servicio de cliente de SMS
  • SMS_REPORTING_POINT
  • SMS_SERVER_LOCATOR_POINT
  • SMS_SQL_MONITOR
  • SMS_SITE_COMPONENT_MANAGER

Disponibilidad de SMS

  • Ejecute los informes de disponibilidad de SMS 2003 para revisar la disponibilidad de los servidores y componentes de SMS.

Vea también

Conceptos

Tareas diarias de SMS 2003
Tareas semanales de SMS 2003
Tareas de la consola de administrador de SMS 2003

Otros recursos

Realización de tareas de operaciones para el módulo de administración de SMS 2003
Solución de problemas del módulo de administración de SMS 2003
Referencia para el módulo de administración de Microsoft Systems Management Server 2003


Tareas de la consola de administrador de SMS 2003

Las tareas de la consola de administrador de SMS requieren la instalación de la consola de administrador de Microsoft Systems Management Server (SMS) 2003 SP2 o versiones posteriores en el mismo equipo que la Consola del operador de Operations Manager 2007. Una vez instalada la consola de administrador de SMS, debe cerrar la sesión y volver a iniciar sesión en Windows para habilitar la funcionalidad de la tarea.

Tareas del módulo de administración

Tarea | Descripción
Consola de administrador de SMS | Abre la consola de administrador de SMS dirigida al equipo seleccionado actualmente. Esto se aplica a los equipos que alojan la función de servidor de sitio de SMS.
Todos los mensajes de estado de SMS | Solicita el servidor de sitio del equipo, abre una ventana de MMC y ejecuta una consulta de mensaje de estado para devolver todos los mensajes de estado asociados con el equipo seleccionado actualmente. Esto se aplica a todos los sistemas.
Administrador de servicios de SMS | Abre el administrador de servicios de SMS dirigido al equipo seleccionado actualmente. Esto se aplica a los equipos que alojan la función de servidor de sitio de SMS.
Explorador de recursos de SMS | Solicita el servidor de sitio del equipo y abre una ventana de MMC con el explorador de recursos de SMS para mostrar los datos para el equipo seleccionado actualmente. Esto se aplica a todos los sistemas.

Vea también

Conceptos

Tareas diarias de SMS 2003
Tareas semanales de SMS 2003
Tareas mensuales de SMS 2003

Otros recursos

Realización de tareas de operaciones para el módulo de administración de SMS 2003
Solución de problemas del módulo de administración de SMS 2003
Referencia para el módulo de administración de Microsoft Systems Management Server 2003


Solución de problemas del módulo de administración de SMS 2003

Hay una serie de acciones que puede llevar a cabo para solucionar problemas del producto:

  • Asegúrese de que Operations Manager 2007 esté instalado correctamente.
  • Asegúrese de que Operations Manager 2007 se haya configurado correctamente.
  • Asegúrese de que todos los sistemas de Microsoft® Systems Management Server (SMS) se hayan configurado con la información de Operations Management.
  • Asegúrese de que todos los equipos administrados con Proveedores de SMS y bases de datos del sitio de SMS tengan instalado el agente Operations Manager 2007 y estén habilitados para conexiones proxy con otros equipos.
  • Compruebe que la importación del módulo de administración se haya completado correctamente.
  • Asegúrese de que estén habilitadas todas las entidades pertinentes, como las reglas y las alertas asociadas.
  • Asegúrese de que los grupos de equipos estén rellenados con los equipos correctos. Puede usar las vistas para llevar a cabo esta inspección.
  • Asegúrese de que no haya alertas de error de latido.
  • Asegúrese de que el intervalo de latidos se haya configurado correctamente y de que las reglas se propaguen al equipo del agente Operations Manager 2007.
  • Asegúrese de que los servicios dependientes, como el Instrumental de administración de Windows (WMI), el servicio de publicación World Wide Web, el servicio de administración de Internet Information Services (IIS), el Servicio de transferencia inteligente en segundo plano (BITS) y Microsoft SQL Server estén instalados y funcionen correctamente en los sistemas de sitio de SMS 2003.
  • Asegúrese de que Operations Manager 2007 no deshabilite automáticamente ninguna regla debido a una activación excesiva, sintaxis incorrecta o secuencias de comandos demasiado largas.
  • Asegúrese de que todos los contadores de rendimiento estén instalados correctamente.

En esta sección

Problemas conocidos de SMS 2003

Vea también

Conceptos

Escenarios de supervisión del módulo de administración
Implementación del módulo de administración de SMS 2003

Otros recursos

Introducción al módulo de administración de Systems Management Server 2003
Realización de tareas de operaciones para el módulo de administración de SMS 2003
Referencia para el módulo de administración de Microsoft Systems Management Server 2003


Problemas conocidos de SMS 2003

A continuación se describen los problemas conocidos del módulo de administración de Systems Management Server 2003 para Operations Manager 2007.

El modo de mantenimiento y la vista de topología requieren SMS 2003 SP3

SMS puede interferir con la instalación de software que no sea de Microsoft que detenga el servicio WMI

Supervisión de WMI

Las tareas de SMS sólo se ejecutan en el contexto de usuario usado para instalar la consola de administrador de SMS 2003

El módulo de administración de SMS 2003 no puede detectar el sitio secundario de SMS si la consola de administrador de SMS está instalada en el mismo equipo

El sistema se reinicia

La secuencia de comandos Monitor SMS Status Messages de SMS 2003

La secuencia de comandos Monitor Site Summarizer de SMS 2003 se encuentra fuera del intervalo del generador de resumen de estado del sistema de sitio predeterminado

Las reglas de mensaje de estado que supervisan la conectividad del remitente tienen una dependencia del funcionamiento del remitente

Supervisión de BITS deshabilitada de forma predeterminada

La ruta de acceso al proveedor de aplicaciones se define como C:\SMS\Logs de forma predeterminada, lo que puede no ser válido en todos los servidores de sitio de SMS

El modo de mantenimiento y la vista de topología requieren SMS 2003 SP3

SMS 2003 SP3 es necesario en servidores de sitio de SMS 2003 para habilitar el modo de mantenimiento o para ver la topología de sitios con Operations Manager 2007. Para obtener más información, consulte Configuración de SMS compatible.

SMS puede interferir con la instalación de software que no sea de Microsoft que detenga el servicio WMI

El módulo de administración de SMS 2003 puede interferir con la instalación de software que no sea de Microsoft que tenga acceso al servicio WMI. La mayoría de las secuencias de comandos del módulo de administración usan WMI para obtener acceso al registro y poder reiniciar el servicio WMI. Si el servicio WMI está habilitado y se puede iniciar, el Modelo de objetos componentes (COM) reiniciará WMI correctamente.

Si un software que no sea de Microsoft se detiene, pero no deshabilita WMI durante una instalación o una actualización, el reinicio automático de la secuencia de comandos de WMI puede afectar a la instalación de software que no sea de Microsoft. Esto puede suponer un problema para WMI o las actualizaciones del proveedor WMI si el programa de instalación no deshabilita primero el servicio WMI. Este problema se aplica a cualquier cliente de WMI.

Supervisión de WMI

  • Las siguientes reglas basadas en el suceso del sistema Windows NT® registran sucesos desde el administrador de control de servicios para errores de servicio inesperados. No hay limitaciones del sistema operativo conocidas para estas reglas.
  • Error de servicio dependiente de SMS 2003: el Instrumental de administración de Windows finalizó inesperadamente.
  • Error de servicio dependiente de SMS 2003: el Instrumental de administración de Windows no responde al iniciarse.
  • Error de servicio dependiente de SMS 2003: error del Instrumental de administración de Windows al iniciarse.
  • Error de servicio dependiente de SMS 2003: no se puede iniciar sesión en el Instrumental de administración de Windows.
  • Error de servicio dependiente de SMS 2003: el Instrumental de administración de Windows depende de otro servicio que no se puede iniciar o no existe.

Las tareas de SMS sólo se ejecutan en el contexto de usuario usado para instalar la consola de administrador de SMS 2003

Este problema se produce porque la variable de entorno SMS_UI_PATH se creó con la instalación de la consola de administrador de SMS como una variable de entorno de usuario y no como una variable de entorno del sistema. Para solucionar este problema, puede copiar el nombre y el valor para SMS_UI_PATH, y definir las variables anteriores como variables del entorno del sistema, de manera que todos los operadores y los administradores puedan invocar tareas sin errores.

El módulo de administración de Systems Management Server 2003 no puede detectar el sitio secundario de SMS si la consola de administrador de SMS está instalada en el mismo equipo

La instalación de la consola de administrador de Systems Management Server 2003 en un equipo que también es un servidor de sitio secundario de SMS hace que el módulo de administración de SMS 2003 no identifique el servidor como un servidor de sitio secundario de SMS.

Para solucionar este problema, al instalar la consola de administrador de SMS en un servidor de sitio secundario de SMS, debe cambiar el valor de registro HKLM\SOFTWARE\Microsoft\SMS\Setup\Type de 4 a 2.

El sistema se reinicia

En caso de producirse un reinicio del sistema, sólo recibirá algunas alertas de detención de servicio. No hay ningún suceso o alerta que indique que el sistema se ha reiniciado. La mejor solución para detectar un cierre esperado o inesperado del sistema consiste en instalar el módulo de administración del sistema operativo Microsoft Windows Server, que contiene una regla que avisa de los reinicios del sistema. Otros métodos para determinar si se ha producido un reinicio del sistema son comprobar los registros de SMS, el registro de sucesos de Operations Manager 2007 NT, los registros de sucesos de Windows NT y los sucesos de Operations Manager 2007 para la comunicación del agente.

La secuencia de comandos Monitor SMS Status Messages de SMS 2003

Cuando la tabla de mensajes de estado de SMS supere los 4.294.967.296 mensajes, el identificador se reinicia en cero. La secuencia de comandos Monitor SMS Status Messages de SMS 2003 no tiene ningún mecanismo para detectar cuándo el identificador de registro se ha reiniciado en cero. La secuencia de comandos sólo espera el identificador de registro del último mensaje de estado que ha procesado. Si el identificador de registro se reinicia, el módulo de administración no puede detectar ningún mensaje de estado nuevo.

En el servidor de sitio, tenga en cuenta el valor de registro Next Status Message Record ID de la clave de registro HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER. Éste es el siguiente identificador de registro incluido en la tabla StatusMessages de SQL. Si este valor es menor que el valor LastRecordID, la tabla StatusMessages ha realizado un bucle invertido y se ha reiniciado. La secuencia de comandos no procesa mensajes de nuevo hasta que el valor de registro Next Status Message Record ID es mayor que el valor LastRecordID del archivo VarSet.

Debe supervisar periódicamente la clave de registro HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER del servidor de sitio para el identificador de registro del siguiente mensaje de estado. Las organizaciones o los sitios pequeños que se encuentran en un nivel bajo de la jerarquía de SMS deben comprobar su clave de registro cada dos o tres meses. Los sitios o las organizaciones grandes con varios sitios secundarios deben comprobar esta clave de registro todos los meses. Si el valor alcanza 4.294.967.296, supervíselo con más frecuencia. Una vez que el identificador de registro se ha restablecido en cero, debe desbloquear la supervisión de mensajes de estado en el equipo que ejecuta el servidor de base de datos del sitio de SMS. La ubicación de la base de datos del sitio de SMS se designa al instalar SMS.

Una forma de automatizar la supervisión de claves de registro es crear un atributo de equipo y un grupo de equipos para supervisar los equipos que se aproximan a este umbral.

Para buscar todas las bases de datos del sitio de SMS en el grupo de configuración

  1. En la Consola del operador, haga clic en el botón Crear.
  2. En el panel de resultados, haga clic con el botón secundario en Microsoft Systems Management Server (SMS) 2003 y, a continuación, seleccione Ver miembros del grupo.

Para desbloquear la supervisión de mensajes de estado

  1. En el equipo que aloja la función de base de datos del sitio de SMS, en la carpeta Temp de Windows, abra el siguiente archivo de texto: SMS 2003 Monitor SMS Status Messages.VarSet. La entrada LastRecordID_[SMSDatabaseName] es un valor de identificador de registro que indica el último mensaje de estado en la tabla StatusMessages de SQL que la secuencia de comandos ha procesado.
  2. En el equipo que aloja la función de base de datos del sitio de SMS, cambie el valor LastRecordID_[SMSDatabaseName] para el sitio correspondiente en el archivo denominado SMS 2003 Monitor SMS Status Messages.VarSet para que sea igual al valor de registro del identificador de registro Next Status Message menos uno. Si el resultado es 4.294.967.296, defina el valor como cero y guarde el archivo.

La secuencia de comandos Monitor Site Summarizer de SMS 2003 se encuentra fuera del intervalo del generador de resumen de estado del sistema de sitio predeterminado

El intervalo en el que la secuencia de comandos Monitor Site System Summarizer de SMS 2003 se ejecuta se diferencia en 10 minutos del intervalo de sondeo del generador de resumen de estado del sistema de sitio de una hora. Aunque la consola de administrador de SMS permite configurar la programación del generador de resumen de estado del sistema de sitio, no cambia este intervalo de sondeo, sino sólo el intervalo para otras tareas de mantenimiento. La secuencia de comandos Monitor Site System Summarizer de SMS 2003 se ejecuta mediante un proveedor de sucesos con hora, Schedule Every 60 Minutes Synchronize at 00:10. El período de diferencia de 10 minutos concede tiempo para que el generador de resumen de estado del sistema de sitio complete su ciclo. Si este período de tiempo es insuficiente, debería extenderse; de lo contrario, la secuencia de comandos termina antes de que el generador de resumen del sistema de sitio complete su ciclo. Esto puede tener como resultado que se genere un informe del estado anterior del sistema de sitio.

Las reglas de mensaje de estado que supervisan la conectividad del remitente tienen una dependencia del funcionamiento del remitente

Si el remitente no se puede conectar a un sitio principal, los mensajes de estado no suben en la jerarquía de SMS y el módulo de administración no genera una alerta en dichos mensajes de estado. Esto es especialmente significativo en el caso de los sitios secundarios, que tienen la secuencia de comandos SMS 2003 Monitor Status Message en ejecución. Las siguientes reglas de mensaje de estado que supervisan la conectividad del remitente tienen una dependencia en el funcionamiento del remitente y están deshabilitadas de forma predeterminada:

  • Estado de SMS 2003: el remitente no se puede conectar con el sitio remoto en la LAN (seguridad estándar).
  • Estado de SMS 2003: el remitente no se puede conectar con el sitio remoto mediante la conexión RAS.
  • Estado de SMS 2003: el remitente no se puede conectar con el sitio remoto en la LAN (seguridad avanzada).
Nota
Todas estas reglas están deshabilitadas de forma predeterminada. Para que estas reglas funcionen, cada servidor de base de datos del sitio de SMS, o como mínimo el sitio central, debe ser un equipo administrado.

Se ha proporcionado un método de supervisión paralelo basado en un proveedor de registro de aplicación, el registro de remitente de SMS 2003. Estas reglas están habilitadas de forma predeterminada. Si deshabilita estas reglas, debe contemplar la posibilidad de habilitar las reglas de mensaje de estado complementarias anteriores. No habilite ambos conjuntos de reglas porque aumentarán las alertas duplicadas. No hay ninguna consolidación de estas reglas de sucesos o alertas que procese el mensaje de estado y la regla de componente activa.

  • Componente de SMS 2003: el remitente no se puede conectar con el sitio remoto en la LAN (seguridad estándar).
  • Componente de SMS 2003: el remitente no se puede conectar con el sitio remoto mediante la conexión RAS.
  • Componente de SMS 2003: el remitente no se puede conectar con el sitio remoto en la LAN (seguridad avanzada).

Para que estas reglas funcionen, debe modificarlas para que señalen los archivos de registro de SMS. Además, cada servidor SMS con un remitente debe ser un equipo registrado.

Supervisión de BITS deshabilitada de forma predeterminada

Debido a que el Servicio de transferencia inteligente en segundo plano (BITS) se inicia con la demanda por parte del cliente avanzado de SMS, la siguiente regla está deshabilitada de forma predeterminada en el módulo de administración de SMS 2003:

  • Servicio dependiente de SMS 2003 que ejecute: Servicio de transferencia inteligente en segundo plano

Debe habilitar esta regla si tiene el servicio configurado para iniciarse automáticamente.

Las siguientes reglas están habilitadas de forma predeterminada para supervisar problemas con el servicio BITS y para informar si el host de agente de SMS no puede iniciar el servicio BITS cuando sea necesario:

  • Error de servicio de SMS 2003: el Servicio de transferencia inteligente en segundo plano finalizó inesperadamente.
  • Error de servicio de SMS 2003: el Servicio de transferencia inteligente en segundo plano no responde al iniciarse.
  • Error de servicio de SMS 2003: error de inicio del Servicio de transferencia inteligente en segundo plano.
  • Error de servicio de SMS 2003: el Servicio de transferencia inteligente en segundo plano no pudo iniciar sesión.

Error de servicio de SMS 2003: el Servicio de transferencia inteligente en segundo plano depende de otro servicio que no se pudo iniciar o que no existe.

La ruta de acceso al proveedor de aplicaciones se define como C:\SMS\Logs de forma predeterminada, lo que puede no ser válido en todos los servidores de sitio de SMS

Hay cuatro reglas de componente que usan el proveedor de registro de aplicación para supervisar los archivos de registro de SMS en C:\SMS\Logs:

  • Componente de SMS 2003: el remitente no se puede conectar con el sitio remoto en la LAN (seguridad estándar).
  • Componente de SMS 2003: el remitente no se puede conectar con el sitio remoto mediante la conexión RAS.
  • Componente de SMS 2003: el remitente no se puede conectar con el sitio remoto en la LAN (seguridad avanzada).
  • Componente de SMS 2003: Distribution Manager no pudo procesar un paquete.

Las reglas de remitente están habilitadas de forma predeterminada mientras que la regla de Distribution Manager está deshabilitada de forma predeterminada. Si ha instalado SMS en una unidad distinta de C o ha modificado la carpeta predeterminada en que se almacenan los registros, debe modificar esta regla antes de habilitarla. Si esta regla no se modifica para buscar la carpeta correspondiente para los archivos de registro, la alerta no devuelve la información que ha buscado.

Cuando modifica la regla para designar la ruta de acceso correcta, puede escribir una ruta de acceso a los archivos de registro o crear una variable de entorno y modificar la regla para usar dicha variable. Si escribe una ruta de acceso, debe trabajar en todos los servidores de sitio afectados por esta regla. Si tiene dos rutas de acceso diferentes, una para los servidores de sitios principales y otra para servidores de sitios secundarios, use los siguientes pasos:

Para modificar el xml de reglas de componente para usar una ruta alternativa para archivos de registro

  1. En Operations Manager 2007 Operations Console, haga clic en el botón Crear, expanda Objetos del módulo de administración y, a continuación, haga clic en Reglas.

  2. En el panel Detalles, haga clic con el botón secundario en la regla que desea modificar y seleccione Propiedades.

  3. Haga clic en la ficha Configuración.

  4. En el panel Respuestas , seleccione la respuesta cuyo xml desea editar.

  5. Haga clic en el botón Editar…. Se abre el cuadro de diálogo GenerateAlert - Properties.

  6. En la ficha Configuración del cuadro de diálogo GenerateAlert - Properties, haga clic en el botón Editar….

  7. Edite la cadena de directorio según corresponda. Haga clic en Aceptar, en Aplicar y, a continuación, en Aceptar para guardar el cambio.

Vea también

Conceptos

Configuración de SMS compatible

Otros recursos

Solución de problemas del módulo de administración de SMS 2003
Introducción al módulo de administración de Systems Management Server 2003
Referencia para el módulo de administración de Microsoft Systems Management Server 2003


Referencia para el módulo de administración de Microsoft Systems Management Server 2003

Estos materiales de referencia proporcionan orientaciones para usar Operations Manager 2007 y Systems Management Server 2003.

En esta sección

Recursos adicionales para el módulo de administración de Microsoft Systems Management Server 2003

Sitios y componentes del módulo de administración de SMS 2003

Grupos de equipos para SMS 2003

Grupo de reglas de SMS 2003

Proveedores de SMS 2003

Secuencias de comandos de SMS 2003

Vistas de Microsoft SMS 2003

Diagramas de SMS 2003

Informes de SMS 2003

Vea también

Conceptos

Escenarios de supervisión del módulo de administración
Implementación del módulo de administración de SMS 2003

Otros recursos

Introducción al módulo de administración de Systems Management Server 2003
Realización de tareas de operaciones para el módulo de administración de SMS 2003
Solución de problemas del módulo de administración de SMS 2003


Recursos adicionales para el módulo de administración de Microsoft Systems Management Server 2003

Los siguientes recursos están disponibles para el módulo de administración de Microsoft Systems Management Server 2003.

Microsoft Operations Manager 2007

Para obtener acceso a la documentación de producto principal de Operations Manager 2007 en Internet y a la información más reciente acerca de System Center Operations Manager 2007, consulte la página web de producto de Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

SMS 2003

Toda la información que necesita para implementar y usar SMS 2003 se proporciona en la documentación de producto principal, la Ayuda de la consola de administrador de SMS, el glosario de SMS y la biblioteca en línea de SMS. Puede tener acceso a la biblioteca en línea de SMS y a la Ayuda de la consola de administrador de SMS desde dicha consola.

Biblioteca en línea de SMS 2003

La biblioteca en línea de SMS proporciona punteros para toda la información que necesita para implementar y usar SMS. Hay dos formas de ejecutar la biblioteca en línea de SMS después de instalar SMS 2003:

  • En el menú Inicio, haga clic en Programas, en Systems Management Server y, a continuación, seleccione SMS Online Library.
  • Haga clic con el botón secundario en SMS Online Library en el árbol de la consola de administrador de SMS y, a continuación, haga clic en Run Online Library.

La biblioteca en línea incluye lo siguiente:

  • Las notas de la versión de SMS 2003, que contienen información clave acerca de SMS.
  • Una sección de novedades de esta versión de SMS, en la que se describen las diferencias entre esta versión de SMS 2003 y las versiones anteriores.
  • Un vínculo a la página web de documentación de producto de SMS.
  • Vínculos a páginas de descarga para SMS 2003 Device Management Feature Pack y SMS 2003 Operating System Deployment Feature Pack.

SMS en Internet

  • Para buscar informes técnicos e información acerca de productos relacionados, consulte el sitio web de producto de Microsoft Systems Management Server 2003. El sitio web de SMS también ofrece información específica acerca de cómo usar SMS con otros productos de Microsoft, como Microsoft Windows® XP y Microsoft Office XP.
  • Para obtener información acerca de vínculos a versiones descargables y que se pueden buscar de la documentación de producto principal de SMS 2003, consulte la página web de la documentación de producto de Systems Management Server 2003.
  • Microsoft mantiene muchos grupos de noticias gratuitos en los que puede exponer sus preguntas y obtener soporte gratuito de personas como usted y, a menudo, de miembros del equipo de producto de SMS. Visite la página web de la comunidad de Systems Management Server para obtener más información acerca de los grupos de noticias gratuitos.
  • Para obtener artículos de instrucciones técnicos, P+F, difusiones web, grupos de noticias, etc., consulte la página web de soporte para Systems Management Server.
  • Para buscar en Microsoft Knowledge Base y en otros recursos técnicos para ver respuestas precisas y rápidas a preguntas de SMS, visite el sitio web de Ayuda y soporte técnico de Microsoft. Puede consultar en Knowledge Base y buscar un archivo acerca de un problema específico usando el número "Qxxxxxx" o el número "xxxxxx" asignado al problema.

Comentarios

  • Ayude al equipo de documentación de SMS a enviar la clase de información de producto que más necesita proporcionándonos sus comentarios. Envíenos sus comentarios acerca de la documentación a la página de documentación de SMS.

Vea también

Conceptos

Sitios y componentes del módulo de administración de SMS 2003
Grupos de equipos para SMS 2003
Grupo de reglas de SMS 2003
Proveedores de SMS 2003
Secuencias de comandos de SMS 2003
Vistas de Microsoft SMS 2003
Diagramas de SMS 2003
Informes de SMS 2003


Sitios y componentes del módulo de administración de SMS 2003

Los componentes de SMS 2003 son el servidor de sitio central de SMS, la base de datos de sitio de SMS y la consola de administrador de SMS. Normalmente, el servidor de sitio central de SMS, la base de datos de sitio de SMS y la consola de administrador de SMS residen en el mismo servidor y cada función del sistema de sitio reside en un servidor dedicado. Un servidor de sitio central y una base de datos, junto con cualquier función del sistema de sitio, conforman un único sitio de SMS. Un único sitio de SMS puede incluir varias funciones del sistema de sitio duplicadas. Por ejemplo, un único sitio puede incluir varios puntos de acceso cliente (CAP). Los sitios de SMS 2003 se pueden clasificar en niveles. Un único sitio de SMS puede no incluir algunas funciones de servidor de sitio, como el punto de ubicación de servidor.

El módulo de administración de SMS 2003 está diseñado para supervisar los componentes del servidor SMS. Este módulo de administración no está diseñado para supervisar la funcionalidad de SMS en equipos cliente de SMS. Sin embargo, Operations Manager 2007 se puede usar para supervisar otras aplicaciones que residen en un equipo cliente de SMS.

Para obtener más información acerca de los componentes de SMS 2003, vea la biblioteca en línea de SMS 2003. Para obtener vínculos a la documentación de SMS 2003, vea la sección Recursos adicionales para el módulo de administración de Microsoft Systems Management Server 2003 en esta guía.

Las funciones y los componentes del servidor clave son:

  • Punto de acceso cliente
  • Punto de distribución
  • Punto de administración
  • Punto de ubicación de servidor
  • Punto de notificación
  • Servidor de sitio
  • Base de datos de sitio
  • Remitentes
  • Cliente avanzado
  • Cliente heredado
  • Proveedor de SMS
  • Consola de administrador de SMS

Punto de acceso cliente

La función del CAP es el punto de contacto entre los clientes heredados y el servidor de sitio de SMS. El CAP pasa todos los datos del cliente heredado al servidor de sitio. Los equipos del cliente heredado se ponen en contacto con el CAP para obtener la información de administración del servidor de sitio de SMS. Un CAP sirve sólo para un sitio de SMS y se instala de forma predeterminada en el servidor de sitio. El CAP también:

  • Proporciona instrucciones de configuración específicas y archivos para el cliente heredado durante la instalación del cliente y cuando se realizan cambios después de la instalación del cliente.
  • Es la ubicación en que los equipos de cliente heredado comprueban los anuncios.
  • Recibe datos de clientes heredados, que reenvía al servidor de sitio de SMS. Por ejemplo, cuando un cliente completa inventario de hardware o software y ha creado un archivo de datos de inventario, envía estos datos al CAP. Los mensajes de estado que se originen en el cliente se replican en el CAP.

Punto de distribución

El punto de distribución almacena archivos de origen del paquete de SMS que los clientes SMS usan cuando instalan programas de software distribuidos por SMS. Cuando el administrador de SMS anuncia un programa, el anuncio y la información del programa se ponen a disposición de los clientes mediante un CAP para clientes heredados o mediante un punto de administración para clientes avanzados.

Cuando se configura SMS, el servidor de sitio se asigna automáticamente a la función del punto de distribución. El administrador de SMS puede habilitar el punto de distribución para usar el Servicio de transferencia inteligente en segundo plano (BITS), que permite a los clientes avanzados descargar archivos de paquetes incrementales.

Los clientes avanzados usan BITS para detectar automáticamente la capacidad de conexión de la red del cliente y ajustar las velocidades de transferencia de manera eficaz. Esto sólo se admite en clientes con los sistemas operativos Microsoft Windows 2000, Microsoft Windows XP Professional y Microsoft Windows Server™ 2003.

Punto de administración

El punto de administración es el punto de contacto principal entre los clientes avanzados y el servidor de sitio de SMS. Un sitio de SMS sólo tiene un punto de administración predeterminado, aunque se pueden configurar varios puntos de administración con el servicio de equilibrio de carga de red de Windows. De forma similar a la relación entre los CAP y los clientes heredados, un punto de administración:

  • Proporciona detalles específicos de configuración del cliente (denominada también directiva de clientes avanzados) a los clientes avanzados después de la instalación del cliente.
  • Es la ubicación en que los equipos de cliente avanzado comprueban los anuncios.
  • Busca puntos de distribución para clientes avanzados.
  • Recibe información de inventario, disponibilidad de software y estado de los clientes avanzados y la reenvía al servidor de sitio de SMS.

Punto de ubicación de servidor

El punto de ubicación de servidor busca los CAP para clientes heredados y puntos de administración para clientes avanzados. El punto de ubicación de servidor se usa principalmente en la instalación del cliente. El punto de ubicación de servidor:

  • Busca un punto de administración para el cliente avanzado si dicho cliente avanzado está configurado para la asignación de sitio automática de SMS.
  • Proporciona a los clientes avanzados la ubicación del punto de administración durante la instalación del cliente iniciada mediante secuencias de comandos de inicio de sesión y durante una instalación sin suficientes credenciales.
  • Proporciona la asignación de sitio de SMS al cliente heredado y busca los CAP durante la instalación del cliente iniciada mediante secuencias de comandos de inicio de sesión.

Punto de notificación

Un punto de notificación es un servidor que ejecuta Internet Information Services (IIS), que aloja el código del Visor de informes y cualquier informe complementario. Un punto de notificación sólo se comunica con su servidor de base de datos del sitio de SMS.

Cliente avanzado

SMS 2003 satisface la necesidad de equipos portátiles con el cliente avanzado. El cliente avanzado es compatible con todo el conjunto de características de SMS, que incluye la distribución de software, la administración de activos y la solución de problemas remota. Se pueden administrar usuarios de equipos portátiles y usuarios de equipos de escritorio sin diferenciarlos. El cliente avanzado usa una tecnología de Windows denominada BITS para ofrecer conectividad a todas las operaciones de administración.

Cliente heredado

Puede usar el cliente heredado si su organización necesita administrar equipos que no cumplen los requisitos de compatibilidad con el cliente avanzado. Puede habilitar, configurar y controlar los siguientes métodos de instalación del cliente heredado:

  • Instalación del cliente iniciada mediante secuencias de comandos de inicio de sesión
  • Instalación de inserción de cliente
  • Instalación manual de cliente

Proveedor de SMS

El proveedor de SMS procesa solicitudes de datos de la base de datos del sitio de SMS. La función de proveedor de SMS se instala en el mismo equipo que el servidor de sitio de SMS o la base de datos del sitio de SMS. Se recomienda instalar tanto el proveedor de SMS como la base de datos del sitio de SMS en el servidor de sitio. El proveedor de SMS proporciona acceso a los datos de la consola de administrador de SMS instalada en el sitio.

Consola de administrador de SMS

La consola de administrador de SMS es la interfaz gráfica de usuario usada para administrar SMS. La interfaz usa un complemento de Microsoft Management Console (MMC) que se ofrece con el software del producto SMS. La consola de administrador de SMS se instala de forma predeterminada cuando se instala un servidor de sitio principal. Además, se puede instalar en otros servidores o estaciones de trabajo.

Vea también

Conceptos

Recursos adicionales para el módulo de administración de Microsoft Systems Management Server 2003
Sitios y componentes del módulo de administración de SMS 2003
Grupos de equipos para SMS 2003
Grupo de reglas de SMS 2003
Proveedores de SMS 2003
Secuencias de comandos de SMS 2003
Vistas de Microsoft SMS 2003
Diagramas de SMS 2003
Informes de SMS 2003


Grupos de equipos para SMS 2003

El módulo de administración de SMS 2003 proporciona los siguientes grupos de equipos:

  • Consolas de administrador de Microsoft SMS 2003
  • Clientes avanzados de Microsoft SMS 2003
  • Servidores de sitio centrales de Microsoft SMS 2003
  • Clientes de Microsoft SMS 2003
  • Servidores de punto de acceso cliente de Microsoft SMS 2003
  • Servidores de componentes de Microsoft SMS 2003 basados en IIS
  • Servidores de componentes de Microsoft SMS 2003 basados en SMS Executive
  • Servidores de punto de distribución de Microsoft SMS 2003
  • Servidores de punto de administración de Microsoft SMS 2003
  • Servidores de sitio principal de Microsoft SMS 2003
  • Proveedores de Microsoft SMS 2003
  • Servidores de punto de notificación de Microsoft SMS 2003
  • Servidores de sitio secundario de Microsoft SMS 2003
  • Servidores de Microsoft SMS 2003 Sender
  • Servidores de punto de ubicación de servidor de Microsoft SMS 2003
  • Servidores de Microsoft SMS 2003
  • Servidores de sitio de Microsoft SMS 2003
  • Clientes heredados de Microsoft SMS 2003

Vea también

Conceptos

Recursos adicionales para el módulo de administración de Microsoft Systems Management Server 2003
Sitios y componentes del módulo de administración de SMS 2003
Grupos de equipos para SMS 2003
Grupo de reglas de SMS 2003
Proveedores de SMS 2003
Secuencias de comandos de SMS 2003
Vistas de Microsoft SMS 2003
Diagramas de SMS 2003
Informes de SMS 2003


Grupo de reglas de SMS 2003

En esta sección se incluye una lista de los grupos de reglas y reglas de sucesos del módulo de administración de Systems Management Server (SMS) 2003 que generan alertas y sucesos críticos. Vea la creación en la Consola del operador de Operations Manager 2007 para revisar todas las reglas del grupo de reglas.

Clientes avanzados de SMS

El grupo de reglas de cliente avanzado de SMS contiene reglas para los errores relacionados con los clientes avanzados de SMS.

  • Servicio de SMS 2003 que ejecute: Host de agente de SMS
  • Servicio dependiente de SMS 2003 que ejecute: Servicio de transferencia inteligente en segundo plano
  • Servicio dependiente de SMS 2003 que ejecute: Instrumental de administración de Windows

Puntos de acceso cliente de SMS

El grupo de reglas de punto de acceso cliente de SMS contiene reglas para los errores relacionados con los puntos de acceso cliente de SMS.

  • Servicio de SMS 2003 que ejecute: SMS_EXECUTIVE

Puntos de administración de SMS

El grupo de reglas de punto de administración de SMS contiene reglas para los errores relacionados con los puntos de administración de SMS.

  • Servicio de SMS 2003 que ejecute: Host de agente de SMS
  • Servicio de SMS 2003 que ejecute: SMS_EXECUTIVE
  • Servicio dependiente de SMS 2003 que ejecute: Servicio de publicación World Wide Web
  • Servicio dependiente de SMS 2003 que ejecute: Servicio de administración de IIS
  • Estado de punto de administración de SMS 2003: Estado
  • Umbral de rendimiento de SMS 2003: MP DDR Backlog > 10,000 over 3 hours
  • Umbral de rendimiento de SMS 2003: MP HINV Backlog > 10,000 over 3 hours
  • Umbral de rendimiento de SMS 2003: MP SINV Backlog > 10,000 over 3 hours
  • Umbral de rendimiento de SMS 2003: MP FileCollection Backlog > 10,000 over 3 hours
  • Umbral de rendimiento de SMS 2003: MP Relay Mgr Backlog > 10,000 over 3 hours
  • Umbral de rendimiento de SMS 2003: MP Status Backlog > 10,000 over 3 hours
  • Umbral de rendimiento de SMS 2003: Process - % Processor time (ccmexec) > 95 over 3 hours

Proveedores de SMS

El grupo de reglas de proveedores de SMS contiene reglas para los errores relacionados con el componente de proveedores de SMS de SMS 2003.

  • Servicio dependiente de SMS 2003 que ejecute: Instrumental de administración de Windows

Puntos de notificación de SMS

El grupo de reglas de punto de notificación de SMS contiene reglas para los errores relacionados con los puntos de notificación de SMS.

  • Servicio de SMS 2003 que ejecute: SMS_REPORTING_POINT
  • Servicio dependiente de SMS 2003 que ejecute: Servicio de publicación World Wide Web
  • Servicio dependiente de SMS 2003 que ejecute: Servicio de administración de IIS

Servidores de SMS Sender

El grupo de reglas de servidor de SMS Sender contiene reglas para los errores relacionados con los servidores de SMS Sender.

  • Servicio de SMS 2003 que ejecute: SMS_EXECUTIVE

Puntos de ubicación de servidor de SMS

El grupo de reglas de punto de ubicación de servidor de SMS contiene reglas para los errores relacionados con los puntos de ubicación de servidor de SMS.

  • Servicio dependiente de SMS 2003 que ejecute: Servicio de publicación World Wide Web
  • Servicio dependiente de SMS 2003 que ejecute: Servicio de administración de IIS
  • Servicio de SMS 2003 que ejecute: SMS_SERVER_LOCATOR_POINT

Servidor común de SMS

El grupo de reglas de servidor común de SMS contiene reglas para los errores relacionados con todos los servidores de SMS.

  • Umbral de rendimiento de SMS 2003: Paging File - %Usage > 98 over 3 hours
  • Umbral de rendimiento de SMS 2003: Processor - % Processor time (_Total) > 95 over 3 hours

Servidores de SMS basados en SMS Executive

El grupo de reglas de servidor de SMS basado en SMS Executive contienen reglas para los errores generados en cualquier servidor de sitio que ejecute el servicio de SMS Executive.

  • Umbral de rendimiento de SMS 2003: Process - % Processor time (smsexec) > 95 over 3 hours

Servidores de base de datos del sitio de SMS

El grupo de reglas de los servidores de base de datos del sitio de SMS contiene reglas para los errores relacionados con servidores de base de datos del sitio de SMS.

  • Servicio de SMS 2003 que ejecute: SMS_SQL_MONITOR
  • Servicio dependiente de SMS 2003 que ejecute: MSSQLSERVER
  • Umbral de rendimiento de SMS 2003: SMS SQL Connections > 500 over 2 hours

Servidores de sitio comunes de SMS

El grupo de reglas de servidor de sitio común de SMS contiene reglas para los errores relacionados con todos los servidores de sitio de SMS.

  • Servicio de SMS 2003 que ejecute: SMS_SITE_COMPONENT_MANAGER
  • Servicio de SMS 2003 que ejecute: SMS_EXECUTIVE
  • Umbral de rendimiento de SMS 2003: Site Server Scheduler Jobs Backlog > 10,000 over 3 hours
  • Umbral de rendimiento de SMS 2003: Site Server Scheduler Send Requests Backlog > 10,000 over 3 hours
  • Umbral de rendimiento de SMS 2003: Site Server SWM Backlog > 10,000 over 3 hours
  • Umbral de rendimiento de SMS 2003: Site Server SINV Backlog > 10,000 over 3 hours
  • Umbral de rendimiento de SMS 2003: Site Server HINV Backlog > 10,000 over 3 hours
  • Umbral de rendimiento de SMS 2003: Site Server DDR Backlog > 10,000 over 3 hours

Servidores de base de datos del sitio principales de SMS

El grupo de reglas de servidor de base de datos del sitio principal de SMS contiene reglas para los errores relacionados con todos los servidores de sitio principales de SMS.

  • Umbral de rendimiento de SMS 2003: Site Server SINV Backlog > 10,000 over 3 hours
  • Umbral de rendimiento de SMS 2003: Site Server HINV Backlog > 10,000 over 3 hours

Vea también

Conceptos

Recursos adicionales para el módulo de administración de Microsoft Systems Management Server 2003
Sitios y componentes del módulo de administración de SMS 2003
Grupos de equipos para SMS 2003
Grupo de reglas de SMS 2003
Proveedores de SMS 2003
Secuencias de comandos de SMS 2003
Vistas de Microsoft SMS 2003
Diagramas de SMS 2003
Informes de SMS 2003


Proveedores de SMS 2003

Los tipos de proveedores de datos que usa el módulo de administración de SMS 2003 son los siguientes:

  • Registro de aplicación
  • Suceso con hora
  • Contador de rendimiento de Windows NT

Vea también

Conceptos

Recursos adicionales para el módulo de administración de Microsoft Systems Management Server 2003
Sitios y componentes del módulo de administración de SMS 2003
Grupos de equipos para SMS 2003
Grupo de reglas de SMS 2003
Secuencias de comandos de SMS 2003
Vistas de Microsoft SMS 2003
Diagramas de SMS 2003
Informes de SMS 2003


Secuencias de comandos de SMS 2003

El módulo de administración de SMS 2003 contiene secuencias de comandos de Operations Manager 2007 que se ejecutan automáticamente en el agente y secuencias de comandos que debe ejecutar un administrador. En la siguiente sección se proporciona información adicional acerca de algunas de estas secuencias de comandos.

El agente Operations Manager 2007 ejecuta automáticamente las siguientes secuencias de comandos:

  • SMS 2003 Monitor SMS Status Messages
  • SMS 2003 Monitor Site System Summarizer
  • SMS 2003 Service Discovery – Client
  • SMS 2003 Service Discovery – Server
  • SMS 2003 Site Backup Event Suppression
  • SMS 2003 Monitor Management Point Health
  • SMS 2003: Monitor Management Point Availability
  • SMS 2003 Site Hierarchy Discovery
  • SMS 2003 Monitor SMS Inbox
  • SMS 2003 Monitor SMS Executive Crash Dumps

SMS 2003 Monitor SMS Status Messages

Muchos de los problemas de SMS se detectan y notifican internamente mediante el sistema de estado de SMS. Los componentes de SMS generan los mensajes de estado relacionados con situaciones de interés para los administradores de SMS.

Los mensajes de estado se envían a una base de datos de un sitio de SMS y también a la jerarquía de sitios de una base de datos del sitio principal. Para supervisar el sistema de estado de SMS por sitio, sólo es preciso consultar la tabla de mensajes de estado de SMS de una base de datos de un sitio especificado.

Para la supervisión se ha elegido un conjunto de mensajes de estado que tienen en cuenta los sucesos más importantes para los administradores de SMS. Cuando uno de estos mensajes se detecta en la base de datos, se genera una alerta.

Esta secuencia de comandos realiza lo siguiente:

  • Comprueba si se está ejecutando en un modo administrado sin agente. En caso afirmativo, la secuencia de comandos se cerrará sin realizar más acciones.
  • Inicializa las variables globales.
  • Abre y lee el identificador de registro del último mensaje de estado procesado para cada base de datos del sitio SMS supervisada desde el archivo SMS 2003 Monitor SMS Status Messages.VarSet.
  • Procesa los mensajes de estado encontrados en cada base de datos del sitio de SMS del equipo local.
  • Escribe en el archivo SMS 2003 Monitor SMS Status Messages.VarSet el identificador de registro del último mensaje de estado procesado para cada base de datos del sitio de SMS supervisada y, a continuación, cierra este archivo.

La secuencia de comandos SMS 2003 Monitor SMS Status Messages genera los sucesos con un identificador de suceso establecido en el identificador de mensaje de estado de SMS para el que se está creando el informe. En la tabla S.1 se describe el formato del suceso generado.

Tabla S.1 Formato de los sucesos generados por la secuencia de comandos SMS 2003 Monitor SMS Status Messages

Parámetro | Descripción
EventType | Puede ser Correcto, Error, Advertencia o Información en función de la gravedad del mensaje de estado de SMS
EventNumber | Identificador del mensaje de estado de SMS
Category | Código del sitio de SMS
LoggingDomain | Dominio de los recursos del equipo
LoggingComputer | Nombre NetBIOS del equipo
Parameter1 | Nombre NetBIOS del equipo
Parameter2 | Nombre del módulo de SMS (por ejemplo, Servidor SMS)
Parameter3 | Nombre del componente de SMS
Parameter4 | Identificador del mensaje de SMS
Parameter5 | Código de error Win32
Parameter6 | Código del sitio principal o de nivel superior
Parameter7 | Identificador de registro del mensaje de estado en la tabla de mensajes de estado de SMS
Description | "A new monitored SMS status message on machine <NetBIOS Name> from component <Component Name> with message ID <Message ID> was found in the site <Site Code> database.”

La secuencia de comandos SMS 2003 Monitor SMS Status Messages también informa de los errores mediante el identificador de mensaje de estado número 1102:

EventType= Advertencia

EventNumber= 1102

Description = The script SMS 2003 Monitor SMS Status Messages running under processing rule <ScriptProcessingRuleName> encountered a runtime error. The error message will contain the text “Failed to <ErrorDescription>.”

Todas las reglas de sucesos de supervisión de mensajes de estado de SMS 2003 empiezan con la frase "Estado de SMS 2003:" y se incluyen en el grupo de reglas Servidores de base de datos del sitio de SMS.

  • Estado de SMS 2003: supervisión de mensajes

Estado de SMS 2003: supervisión de mensajes inicia la secuencia de comandos con la programación de SMS 2003 sincronizada cadda 30 minutos a las 00:02. En la página de propiedades Información de la regla se ofrece información de resumen.

  • Estado de SMS 2003: error de secuencia de comandos

Estado de SMS 2003: error de secuencia de comandos supervisa y avisa de los sucesos de error de secuencia de comandos que puedan generarse. Sólo hay un suceso de error de secuencia de comandos (número 1102) que notifica todos los errores de secuencias de comandos. En la página de propiedades Información de la regla se ofrece información acerca de la solución de la alerta.

  • Estado de SMS 2003: <status message name>

Estado de SMS 2003: <nombre del mensaje de estado> supervisa y advierte de los sucesos de mensajes de estado específicos. En la página de propiedades Información de la regla se ofrece información acerca de la solución de la alerta.

Todas las alertas incluyen una descripción del suceso en el formato siguiente, donde $Descripción$ se corresponde con la descripción del suceso:

$Equipo de conexión$ - "Nombre de regla". $Descripción$

El archivo SMS 2003 Monitor SMS Status Messages VarSet se usa para mantener el identificador de registro del último mensaje de estado procesado por base de datos del sitio. El archivo VarSet se encuentra en el directorio Windows\Temp. Se trata de un archivo delimitado por tabuladores con el siguiente formato:

Copiar código
LastRecordID_DBNameRecordID#

Por ejemplo, LastRecordID_SMS_FLA, con un identificador de registro 477860 indica que el último identificador de registro procesado en la base de datos del sitio llamada SMS_FLA fue el número 477860.

Al actualizar el módulo de administración desde una versión anterior, la siguiente información se incluirá en el archivo SMS 2003 Monitor SMS Status Messages VarSet:

Copiar código
LastRecordID476743
LastRecordID_SMS_FLA477860

La primera línea, que no contiene un nombre de base de datos, indica la versión original de la supervisión de mensajes de estado que no admitía la supervisión de varias bases de datos. La segunda línea, que contiene el nombre de la base de datos SMS_FLA, indica que la versión actual de la supervisión de mensajes de estado no admite la supervisión de varias bases de datos.

No se llevará a cabo ninguna acción para usar la primera línea de datos porque en caso de haber varias bases de datos del sitio es difícil determinar con qué base de datos se corresponde. La primera línea de datos no se elimina del archivo VarSet porque puede ser de utilidad para evaluar los nuevos cambios y para garantizar que la supervisión de mensajes de estado comienza con el identificador de registro correcto después de la actualización.

SMS 2003 Monitor Site System Summarizer

Generador de resumen del sistema de sitio

El generador de resumen de estado del sistema de sitio es un subproceso de componente del servicio SMS Executive que mantiene el estado en todos los sistemas del sitio de SMS definidos. De forma predeterminada, este subproceso sondea la hora cada sesenta minutos para comprobar el estado actual. Este intervalo de sondeo se define en el archivo de control de sitio de SMS. Se recomienda no cambiar el intervalo de sondeo. El estado se mantiene en una tabla de la base de datos del sitio de SMS.

Estado DownSince del sistema de sitio

El generador de resumen de estado del sistema de sitio presupone que un sistema de sitio está inactivo cuando no puede ponerse en contacto con él durante alguno de sus intervalos de sondeo. Esto puede deberse a uno de los siguientes factores:

  • El sistema de sitio no está encendido, no está conectado a la red o no funciona correctamente.
  • El generador de resumen de estado del sistema de sitio de SMS no tiene conexión porque no hay ninguna conexión disponible.
  • El generador de resumen de estado del sistema de sitio de SMS no tiene suficientes derechos de acceso para conectarse al sistema de sitio.
  • Problemas de red que impiden que el generador de resumen de estado del sistema de sitio de SMS pueda conectarse al sistema de sitio.
  • El sistema de sitio se encuentra permanentemente fuera de servicio.

Disponibilidad basada en el generador de resumen de estado del sistema de sitio

La secuencia de comandos de disponibilidad del servidor SMS 2003 y el informe de disponibilidad del servidor SMS 2003 usan el estado del generador de resumen de estado del sistema de sitio para crear un informe de disponibilidad. Las mediciones de la disponibilidad del servidor SMS usan el valor de registro DownSince para determinar si un servidor está o no disponible.

Limitaciones de la disponibilidad basada en el generador de resumen de estado del sistema de sitio

En esta sección se describen las limitaciones a las que la secuencia de comandos de disponibilidad del servidor SMS 2003 y el informe de disponibilidad del servidor SMS 2003 están sujetos al usar el estado del generador de informe del sitio para crear un informe de disponibilidad. Las mediciones de la disponibilidad del servidor SMS usan el estado "DownSince" para determinar si un servidor está o no disponible.

La supervisión de la disponibilidad basada en el generador de resumen de estado del sistema de sitio está sujeta a las siguientes limitaciones:

  • El intervalo de sondeo del generador de resumen de estado del sistema de sitio es de una hora. Este intervalo proporciona tiempo suficiente para que el generador de resumen de estado del sistema de sitio pueda sondear todos los sistemas de sitio. Por motivos de rendimiento, este intervalo no se puede cambiar. La propiedad Startup Schedule del archivo de control de sitio, y no la propiedad Wakeup Interval, controla el intervalo de tiempo de espera del generador de resumen. Esto significa que el cambio de la propiedad Wakeup Interval (el valor predeterminado es 60) no surte efecto. El cambio de Startup Schedule tampoco surte ningún efecto. De forma predeterminada, este valor está establecido en cada 15 minutos y el generador de resumen de estado del sistema de sitio sondea los sistemas de sitio cada hora a la hora en punto con independencia del valor establecido en Startup Schedule.
  • La metodología de disponibilidad considera que un sitio no está disponible solamente cuando se producen consecutivamente dos sucesos SMS 2003 Site System Summarizer: Site System is possibly down en un período de dos horas. Esta medida se ha diseñado para dar cuenta de las interrupciones temporales de la red. Esto significa que la disponibilidad se verá afectada por una interrupción de servicio de dos horas, aunque el sitio no haya estado disponible durante un breve espacio de tiempo.
  • El generador de resumen de estado del sistema de sitio no supervisa todas las situaciones en las que SMS puede no estar disponible. Por ejemplo, el generador de resumen de estado del sistema de sitio no considera que SMS no está disponible si los servicios de SMS no se están ejecutando o si la base de datos del sitio de SMS no está disponible como, por ejemplo, cuando el servicio SQL Server está detenido.
  • Los datos de disponibilidad también se ven afectados por los equipos que alojan varias funciones de servidor SMS. El tiempo de inactividad se basa en las alertas que se generan para un sitio que está inactivo. Una sola alerta tiene un valor de inactividad de dos horas. El generador de resumen de estado del sistema de sitio escribe en la base de datos el estado "DownSince" actual de cada objeto del sitio y función de sistema del sitio alojado, concretamente en la tabla Generador de resumen de estado del sistema de sitio.

La secuencia de comandos de supervisión del generador de resumen de estado del sistema de sitio examina cada función de sitio de sistema de la tabla Generador de resumen de estado del sistema de sitio. Si un sistema de sitio aparece marcado como inactivo, se genera un suceso. Posteriormente también se genera una alerta basada en ese suceso. Varias funciones pueden generar varias alertas, con lo que se crearán duraciones de inactividad extendidas. Esto puede traducirse en porcentajes de disponibilidad negativos según el intervalo.

Cada función de servidor SMS, excepto para un punto de distribución de SMS, establece de forma predeterminada dos funciones de servidor SMS: una para la función específica y otra para el servidor de componentes de SMS. Por ejemplo, en el caso de un sistema de sitio que aloja un punto de ubicación de servidor y un punto de notificación, si el servidor ha estado sin conexión más de dos horas (dos intervalos de sondeo del generador de resumen de estado del sistema de sitio), el generador de resumen de estado del sistema de sitio marcará como inactivas ambas funciones y sus funciones de servidor de componentes de SMS.

Sin embargo, sólo se generarán tres alertas por cada intervalo de sondeo durante un periodo de dos horas: una para cada función de servidor y otra para el servidor de componentes físicos que aloja las dos funciones de servidor. Como resultado se obtendría una disponibilidad negativa porque se marcarían seis horas como no disponibles para un período de dos horas.

  • La programación de 60 minutos, con un retraso de 10 minutos con respecto a la hora en punto, se ha establecido como valor predeterminado para que la secuencia de comandos SMS 2003 Monitor Site System Summarizer se ejecute 10 minutos después del inicio del intervalo de sondeo de 1 hora del generador de resumen de estado del sistema de sitio. Si el generador de resumen tarda más de 10 minutos en completar su ciclo, el retraso del proveedor de sucesos con hora aumentará en correspondencia. De lo contrario, los mensajes de estado de sistema de sitio actual se perderán.

SMS 2003: Monitor Management Point Availability

La secuencia de comandos SMS 2003 Monitor Management Point Availability admite Management Point Availability Report. La disponibilidad se basa en el estado de un punto de administración y aprovecha el siguiente valor de estado del registro:

DWORD value HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState

Basada en una programación configurable y un intervalo de notificación, la secuencia de comandos lee y, a continuación, notifica mediante un suceso de Operations Manager 2007 la duración del estado incorrecto (el valor del registro es 1 y no 0).

Estos sucesos de datos de disponibilidad se escriben en la base de datos OperationsManager y en la base de datos OperationsManagerDW. A continuación, se puede ejecutar un informe de Operations Manager 2007 que muestre el tiempo total durante el cual el punto de administración estuvo inactivo durante un intervalo especificado junto con un porcentaje de disponibilidad.

El administrador de control del módulo de administración se encarga de mantener el valor de registro MPHealthState. Se actualiza cada seis minutos.

Esta secuencia de comandos realiza las siguientes acciones:

  • Comprueba si se está ejecutando en el modo administrado sin agente. En caso afirmativo, la secuencia de comandos se cerrará sin realizar más acciones. La secuencia de comandos usa el archivo VarSet local para las variables persistentes, por lo que el agente Operations Manager 2007 deberá instalarse.
  • Inicializa las variables globales.
  • Obtiene los parámetros de entrada ScheduledInterval y ReportingInterval, en minutos.
  • Comprueba que los parámetros de entrada no estén vacíos, sean 0 o negativos. Si están vacíos, son 0 o negativos, se genera un suceso de error de secuencia de comandos para indicar que se ha especificado un valor no válido. La secuencia de comandos también comprueba que el valor ReportingInterval no sea inferior al valor ScheduledInterval. Si lo es, se generará un error de secuencia de comandos para indicar que ReportingInterval no puede ser inferior a ScheduledInterval. Ambos valores implementan un tipo Lng y tienen un valor mínimo de 2147483647 (2G -1).
  • Abre y copia el contenido del archivo SMS 2003 Monitor Management Point Availability.VarSet en una colección local. Si el archivo no existe, no se generará ningún suceso de error de secuencia de comandos. Si el archivo existe pero no se puede abrir, se generará un suceso de error de secuencia de comandos.
  • Comprueba la disponibilidad del punto de administración.
    • Si la versión actual de SMS es anterior a 2.50.3067.0000, la secuencia de comandos se cerrará sin generar un error porque el valor de registro MPHealthState no está presente. El archivo de registro de respuestas del agente, AgentResponses-Configuration Group Name.log, incluirá la instrucción "Monitoring Management Point health is not supported on this SMS build". El registro se habilita al establecer en 1 el valor EnableActiveDebugging DWORD, situado debajo de la clave HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager.
    • Obtiene el estado del punto de administración actual a partir del valor DWORD del registro HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState. Si el valor no se puede obtener, la secuencia de comandos se cierra sin generar un error porque el administrador de control del módulo de administración aún no lo ha creado.
    • Obtiene la fecha y la hora de inicio de la colección VarSet. Si es la primera vez que se ejecuta la secuencia de comandos y es el comienzo de un nuevo período de informes, no habrá ninguna entrada. La secuencia de comandos inicializa la duración y la fecha de inicio en la colección VarSet antes de salir sin generar ningún error. Establece la duración en 0 y la fecha de inicio en la fecha y hora actuales.
    • Para el intervalo de informes actual, si el valor de registro MPHealthState es 1, la secuencia de comandos aumenta la duración de no disponibilidad en la colección VarSet en función del intervalo de programación especificado.
    • Notifica, mediante la creación de un suceso de datos de disponibilidad, si el intervalo de informes y el punto de administración no han estado disponibles. La secuencia de comandos vuelve a establecer la duración en 0 y restablece la fecha de inicio de la colección VarSet a la hora local del siguiente período de informes.
    • Si se produce un error al comprobar la disponibilidad del punto de administración, se genera un error de secuencia de comandos.

Número de suceso = 1102

Tipo de suceso = Advertencia

Mensaje = "The script 'SMS 2003 Monitor Management Availability' running under processing rule <ProcessingRuleName> encountered a runtime error." CrLf "Failed to check Management Point availability." <ErrorString>

  • Escribe el contenido de la colección VarSet en el archivo SMS 2003 Monitor Management Point Availability.VarSet local y cierra el archivo. El archivo se creará si no existe. Si no se ha establecido ninguna variable VarSet, no aparecerá ninguna entrada que haga referencia a las variables en el archivo. Si se produce un error al escribir en el archivo, la secuencia de comandos genera un error de secuencia de comandos.

SMS 2003: Monitor SMS Inbox

SMS realiza la mayor parte de las principales actividades en el servidor al leer y escribir en los archivos de sus buzones de entrada. Cuando los buzones de entrada de SMS están excesivamente llenos, significa que el procesamiento de SMS está acumulando retrasos. Esto se puede deber a varios motivos como, por ejemplo, archivos defectuosos, procesos detenidos, espacio en disco insuficiente o un nivel de actividad inusual de la distribución del software. Este tipo de problemas suelen producirse en muy raras ocasiones, pero son graves para los clientes con muchos sitios.

Varios contadores de rendimiento para los buzones de entrada de SMS calculan el número de elementos puestos en cola por el componente de servicio en lugar del número real de elementos a la espera de ser procesados en el disco. El componente del servicio de SMS actualizará el contador de rendimiento después de completar la cola actual. Esto puede provocar que los contadores de rendimiento se actualicen con poca frecuencia, lo que impide la detección de los trabajos acumulados importantes. La nueva secuencia de comandos SMS 2003: Monitor SMS Inbox incorpora una supervisión directa al contar los archivos de los buzones de entrada del servidor SMS más importantes y advertir al administrador mediante Operations Manager 2007 en el momento en que el número de archivos de un buzón de entrada concreto supera el valor de umbral configurable del usuario.

Todas las reglas se incluyen en el grupo de reglas de procesamiento Servidores comunes del sitio de SMS, que se hace cargo de estas reglas en los sitios central, principal y secundario. El umbral pasado a la secuencia de comandos se puede configurar por medio de una invalidación.

Por motivos de rendimiento, estas reglas no se usan en los puntos de administración ni en otras funciones de sistema de sitio de SMS.

Programación y configuración opcional

Para minimizar el impacto en el rendimiento ocasionado por la supervisión de los buzones de entrada, las reglas correspondientes se sincronizarán una vez al día. Las reglas se escalonan en intervalos de 15 minutos, empezando a la 01:00, de modo que sólo se ejecute una regla cada vez. Por ejemplo, la primera regla cuenta los archivos presentes en el primer buzón de entrada a la 01:00. La siguiente regla cuenta los archivos presentes en el segundo buzón de entrada a la 01:15 y así sucesivamente hasta que se cuentan todos los buzones de entrada.

Para modificar esta programación, siga los pasos habituales para programar la ejecución de secuencias de comandos de reglas en Operations Manager 2007. No se necesita ninguna configuración adicional para activar esta característica. A continuación se indican algunos cambios de configuración opcionales que puede realizar:

  • Cambie el valor de umbral predeterminado de cada buzón de entrada.
  • Cambie la programación de las reglas de cada buzón de entrada.

Para realizar estos cambios de configuración opcionales, siga los pasos habituales para configurar las reglas de sucesos de umbral de cualquier módulo de administración.

Alertas y valores de umbral

Una alerta se genera cuando el valor configurado para el umbral de una regla de buzón de entrada específica se alcanza cada vez que se procesa la regla de supervisión. Una alerta de error de secuencia de comandos se genera cuando la secuencia de comandos detecta un valor de umbral no válido o un error al intentar supervisar el recuento de archivos de cada buzón de entrada.

Para editar los valores de umbral de rendimiento

  1. En la consola de administrador de Operations Manager 2007, haga clic en Crear.

  2. En el panel Crear, navegue a Crear / Objetos del módulo de administración / Monitores.

  3. En el panel Monitores, cambie el ámbito a SMS server.

  4. Navegue a SMS Server / Entity Health / MOM 2005 Computer Role Health y expanda la función de servidor que desee editar.

    • DB - Servidor de base de datos
    • MP - Servidor de punto de administración
    • SS - Servidor de sitio

  5. Haga doble clic en la regla de supervisión del umbral de rendimiento que desee editar. Se abre el cuadro de diálogo Performance Threshold Properties.

  6. Seleccione la ficha Configuración.

  7. Haga clic en Editar…. Se abre el cuadro de diálogo Configuración xml.

  8. En el texto XML, edite el valor de umbral que desee modificar.

    • Especifique <ValueExpression>, anidado en <CriticalErrorExpression>, para cambiar el umbral de los errores críticos.
    • Especifique <ValueExpression>, anidado en <WarningExpression>, para cambiar el umbral de las advertencias.

  9. Haga clic en Aceptar. Haga clic en Aceptar. Los valores de umbral modificados se distribuyen a los servidores.

El valor de umbral predeterminado para cada regla de supervisión de buzón de entrada se establece en 10.000. Los valores de umbral del parámetro FileCountThreshold de la secuencia de comandos SMS 2003: Monitor SMS Inbox deben establecerse en función de cada entorno. Los valores de umbral válidos están comprendidos entre 1 y 2147483647 (0x7FFFFFFF), ambos incluidos. Los valores de umbral no válidos son cero (0) o números superiores a 2147483647, ya que darían como resultado números negativos en el intervalo de 32 bits.

Para obtener una descripción de las carpetas de los buzones de entrada y su uso en Systems Management Server, vea el tema correspondiente en la página de Ayuda y soporte técnico de Microsoft.

Secuencia de comandos SMS 2003 Monitor SMS Executive Crash Dumps

Esta secuencia de comandos se encuentra en la carpeta Scripts de la consola de administrador de SMS y su nombre es SMS 2003 Monitor SMS Executive Crash Dumps. Esta secuencia de comandos realiza las siguientes acciones:

  • Determina si el equipo de destino se está ejecutando en el modo sin agente. En caso afirmativo, la secuencia de comandos se cerrará sin realizar más acciones. Esta secuencia de comandos usa el archivo VarSet local para las variables persistentes, por lo que el agente Operations Manager 2007 deberá instalarse en todos los equipos de destino.
  • Abre y lee el contenido del archivo SMS 2003 Monitor SMS Executive Crash Dumps.VarSet local en una colección. Si el archivo no existe, no se generará ningún suceso de error de secuencia de comandos. Si el archivo existe pero no se puede abrir, se generará un suceso de error de secuencia de comandos con un mensaje que contiene el siguiente texto:

Error al cargar las variables de secuencia de comandos.

  • Comprueba si se ha producido algún volcado nuevo desde la última comprobación. En caso afirmativo, la secuencia de comandos genera un suceso para notificar el nuevo volcado. Para generar el suceso de error de secuencia de comandos, la secuencia de comandos realiza lo siguiente:
    • Obtiene el directorio de instalación de SMS a partir del registro debajo de la clave de identificación de SMS, valor de registro "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Identification\ Installation Directory". Si la ruta de acceso no se puede obtener, la secuencia de comandos genera un mensaje de suceso de error de secuencia de comandos con el siguiente texto y se cierra:

Error al leer el valor del registro.

  • Crea la ruta de acceso completa al directorio CrashDumps agregando "\Logs\CrashDumps" al directorio de instalación de SMS recuperado.
  • Comprueba si el directorio CrashDumps existe. Si no existe, la secuencia de comandos registra que la existencia de la carpeta no se ha podido comprobar y se cierra sin realizar más acciones. El archivo de registro de respuestas del agente, AgentResponses-Configuration Group Name.log, incluirá la instrucción:

Error al comprobar la existencia del directorio de volcado: <CrashDumpsPath>.

El registro se habilita al establecer en 1 el valor EnableActiveDebugging DWORD, situado debajo de la clave HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager.

  • Obtiene la fecha de creación de la carpeta del último volcado a partir de la colección VarSet.
  • Comprueba si se ha creado algún volcado nuevo y sólo actúa en el más reciente. Para determinar cuál es el más reciente, se utiliza la fecha de creación de la carpeta guardada del último volcado, si está disponible. La comparación de la fecha y la hora se basa en la creación de la carpeta en una resolución de un segundo.
  • Si se ha producido un nuevo volcado o es la primera vez que se ejecuta la secuencia de comandos, dicha secuencia de comandos registra y crea el suceso 1710 para especificar la carpeta y la ruta de acceso del nuevo volcado. La secuencia de comandos guarda la fecha de creación de la carpeta del volcado en la colección VarSet. Si no se ha producido ningún volcado, también queda registrado.
  • Escribe el contenido de la colección VarSet en el archivo SMS 2003 Monitor SMS Executive Crash Dumps.VarSet local y cierra el archivo. El archivo se creará si no existe. Si no se ha establecido ninguna variable VarSet, no aparecerá ninguna entrada que haga referencia a las variables en el archivo. Si se produce un error al escribir en el archivo, se genera un mensaje de suceso de error de secuencia de comandos con el siguiente texto: Error al guardar las variables de secuencia de comandos.

Suceso SMS 2003 Monitoring SMS Executive Crash Dump

La secuencia de comandos SMS 2003 Monitor SMS Executive Crash Dumps informa mediante el suceso 1710 de que se ha producido un volcado, tal y como se indica a continuación:

EventType = Error

EventNumber = 1710

Category = Código del sitio de SMS

Description = SMS Executive in site "XXX" has crashed. For details, see crash dump information under <Drive> \SMS\Logs\CrashDumps\NewFolder.

Suceso de error de secuencia de comandos SMS 2003 Monitoring SMS Executive Crash Dumps

La secuencia de comandos "SMS 2003 Monitor SMS Executive Crash Dumps" informa de los errores de secuencia de comandos en tiempo de ejecución mediante el suceso 1102.

EventType = Advertencia

EventNumber = 1102

Description = The script SMS 2003 Monitor SMS Executive Crash Dumps” running under processing rule SMS 2003 Crash Dumps: Monitoring SMS Executive encountered a runtime error. CrLf “Failed to <Message>." ErrorString

Secuencia de comandos SMS 2003 Server Availability

SMS es una aplicación de empresa crítica que permite administrar la configuración de los equipos de escritorio. Los clientes deben realizar un seguimiento de la disponibilidad de los servicios. El módulo de administración proporciona una secuencia de comandos de Microsoft SQL Server™ de ejemplo para calcular la disponibilidad de sistema de sitio de SMS en función de las alertas que se generan en respuesta a un estado de inactividad del generador de resumen de estado del sistema de sitio de SMS. La disponibilidad se puede determinar para cualquier número de días. Esta métrica se puede usar como ayuda para los contratos de nivel de servicio (SLA) establecidos.

Limitaciones de la secuencia de comandos SMS 2003 Server Availability

La secuencia de comandos SMS 2003 Server Availability está sujeta a las siguientes limitaciones.

Los datos mostrados se limitan a los del intervalo de limpieza de la base de datos de Operations Manager 2007. De forma predeterminada, la secuencia de comandos devuelve los datos de los últimos siete días y de los últimos treinta días. Sin embargo, la base de datos OperationsManager tiene un intervalo de limpieza de 4 días, por lo que la ejecución de la secuencia de comandos con los intervalos de siete y treinta días devuelve los mismos resultados. Si se requieren informes que incluyan períodos más largos, será necesario ampliar el intervalo de limpieza o usar el informe de disponibilidad del servidor SMS 2003, que se ejecuta en la base de datos OperationsManagerDWwhich (almacenamiento a largo plazo para datos operativos). Para períodos más cortos de tiempo, los intervalos de 7 y 30 días de la secuencia de comandos deben cambiarse.

Algoritmo de secuencia de comandos

El generador de resumen del sistema de sitio intenta ponerse en contacto con todos los sistemas de sitio cada hora. Si no consigue ponerse en contacto con un sistema de sitio, dicho sistema se marcará como inactivo en la tabla Generador de resumen de estado del sistema de sitio. Para reducir el número de informes falsos para esta condición, el módulo de administración consolida los sucesos y sólo genera una alerta si se producen dos sucesos en el período de dos horas. Cuando el usuario ejecuta el procedimiento almacenado, el sistema calcula el número de alertas “Site System is possibly down” que se generan durante el número de días especificado, resta el tiempo de inactividad del tiempo disponible total y devuelve un porcentaje de disponibilidad para ese período. Si un equipo no ha registrado ninguna alerta “Site System is possibly down” durante el intervalo especificado, su disponibilidad calculada es del 100%.

No es necesario ejecutar la secuencia de comandos con una frecuencia mayor a los siete días, a no ser que esté interesado en obtener la tendencia diaria.

De forma predeterminada, la secuencia de comandos devuelve los datos de los últimos siete días y de los últimos treinta días. Si se especifica un intervalo de datos más amplio, se obtendrá una cálculo más preciso del tiempo de actividad del servidor. No establezca intervalos de una duración superior a la del ciclo de limpieza de bases de datos de Operations Manager 2007.

En los siguientes ejemplos se muestra cómo aumenta la disponibilidad del servidor cuando se obtienen promedios de datos durante un período de tiempo más amplio:

  • Si existen dos sucesos generados para un equipo en el espacio de dos horas, se genera una alerta. Si se genera una alerta en el período de los últimos diete días, los cálculos serán los siguientes:
    • Número total de horas en siete días = 7 * 24 = 168
    • Número total de horas de inactividad = 1 * 2 = 2
    • Número total de horas de actividad = (168 - 2) = 166
    • Disponibilidad en porcentaje = (166 / 168) * 100 = 98,809%
  • Si se genera una alerta en el período de los últimos treinta días, los cálculos serán los siguientes:
    • Número total de horas en 30 días = 30 * 24 = 720
    • Número total de horas de inactividad = 1 * 2 = 2
    • Número total de horas de actividad = (720 - 2) = 718
    • Disponibilidad en porcentaje = (718 / 720) * 100 = 99,72%
  • Si se genera una alerta en el período de los últimos 84 días, los cálculos serán los siguientes:
    • Número total de horas en 84 días = 84 * 24 = 2016
    • Número total de horas de inactividad = 1 * 2 = 2
    • Número total de horas de actividad = (2016 - 2) = 2014
    • Disponibilidad en porcentaje = (2014 / 2016) * 100 = 99,9%

En los ejemplos siguientes se muestra cómo cambia la disponibilidad del servidor a medida que se registran más alertas durante el mismo período de tiempo:

  • Si se generan dos alertas en el período de los últimos treinta días, los cálculos serán los siguientes:
    • Número total de horas en 30 días = 30 * 24 = 720
    • Número total de horas de inactividad = 2 * 2 = 4
    • Número total de horas de actividad = (720 - 4) = 716
    • Disponibilidad en porcentaje = (716 / 720) * 100 = 99,44%
  • Si se generan tres alertas en el período de los últimos 30 días, los cálculos serán los siguientes:
    • Número total de horas en 30 días = 30 * 24 = 720
    • Número total de horas de inactividad = 3 * 2 = 6
    • Número total de horas de actividad = (720 - 6) = 714
    • Disponibilidad en porcentaje = (714 / 720) * 100 = 99,16%

El intervalo de sondeo del generador de resumen de estado del sistema de sitio está fijado en una hora y no se puede cambiar en la consola de administrador de SMS. La modificación de este intervalo no mejora la precisión de esta secuencia de comandos. Es posible cambiar el intervalo de consolidación de sucesos, pero no se recomienda porque no mejora la precisión del resultado. De hecho, la reducción del intervalo de consolidación reduce la confiabilidad de los resultados porque el intervalo de consolidación de dos horas reduce los resultados falsos ocasionados por una interrupción temporal de la red.

Vea también

Conceptos

Recursos adicionales para el módulo de administración de Microsoft Systems Management Server 2003
Sitios y componentes del módulo de administración de SMS 2003
Grupos de equipos para SMS 2003
Grupo de reglas de SMS 2003
Proveedores de SMS 2003
Secuencias de comandos de SMS 2003
Vistas de Microsoft SMS 2003
Diagramas de SMS 2003
Informes de SMS 2003


Vistas de Microsoft SMS 2003

El módulo de administración de SMS 2003 incluye las siguientes vistas comunes:

  • Alertas
  • Sucesos
  • Diagrama de jerarquías de sitios de SMS 2003
  • Vista de estado
  • Vista de estado de tarea
  • General
  • Rendimiento

También están disponibles las siguientes vistas, personalizadas para SMS 2003:

Diagrama de jerarquías de sitios de SMS 2003

  • Jerarquía de SMS 2003

General

  • Alertas del servidor de sitio central de SMS en las últimas 72 horas
  • Alertas nuevas en las últimas 72 horas

Vistas de rendimiento

Las vistas se pueden configurar para que muestren datos de determinados equipos por vista. Para hacerlo, se recomienda copiar la vista que desea personalizar en Mi área de trabajo, cambiar el nombre de la vista y empezar a personalizar la vista de acuerdo con sus requisitos. La complejidad del gráfico puede reducirse si se selecciona individualmente el contador de los equipos de interés.

Backlogs\Management Point Servers

  • DDR Backlog in the last 48 hours
  • FileCollection Backlog in the last 48 hours
  • HINV Backlog in the last 48 hours
  • Relay Backlog in the last 48 hours
  • SINV Backlog in the last 48 hours
  • Status Backlog in the last 48 hours

Backlogs\Site Servers

  • DDR Backlog in the last 48 hours
  • HINV Backlog in the last 48 hours
  • Scheduler Jobs Backlog in the last 48 hours
  • Scheduler Send Requests Backlog in the last 48 hours
  • SINV Backlog in the last 48 hours
  • SWM Backlog in the last 48 hours

General\Management Point Servers

  • LogicalDisk in the last 48 hours
  • Memory in the last 48 hours
  • Processor in the last 48 hours

General\Site Servers

  • LogicalDisk in the last 48 hours
  • Memory in the last 48 hours
  • Processor in the last 48 hours
Nota
El proveedor de rendimiento de la vista LogicalDisk in the last 48 hours está instalado con el módulo de administración del sistema operativo Microsoft Windows Server.

Tasas de procesamiento

  • *All Message Processing Rates on an SMS 2003 Management Point Server in the last 24 hours
  • *All Message Processing Rates on an SMS 2003 Management Point Server in the last 24 hours
  • *All Report Processing Rates on an SMS 2003 Site Server in the last 24 hours

Processing Rates\Management Point Servers

  • DDRs/sec. in the last 24 hours
  • DM Database Connection Attempts/sec. in the last 24 hours
  • DM DDRs/sec. in the last 24 hours
  • DM Discovery Translation Requests/sec. in the last 24 hours
  • DM DP Locations/sec. in the last 24 hours
  • DM Hardware Inventory Translation Requests/sec. in the last 24 hours
  • DM HINVs/sec. in the last 24 hours
  • DM ISAPI Requests/sec. in the last 24 hours
  • DM Machine Setting Requests/sec. in the last 24 hours
  • DM Package Version Requests/sec. in the last 24 hours
  • DM SINVs/sec. in the last 24 hours
  • DM Software Policy Body Requests/sec. in the last 24 hours
  • DM Software Policy ID Requests/sec. in the last 24 hours
  • DM Status/sec. in the last 24 hours
  • DM Total Setting Requests/sec. in the last 24 hours
  • DP Locations/sec. in the last 24 hours
  • GetAuth Requests/sec. in the last 24 hours
  • GetPolicy Requests/sec. in the last 24 hours
  • HINVs/sec. in the last 24 hours
  • ISAPI Requests/sec. in the last 24 hours
  • MP Locations/sec. in the last 24 hours
  • PA Requests/sec. in the last 24 hours
  • Relay Reports/sec. in the last 24 hours
  • SINVs/sec. in the last 24 hours
  • SPs Executed/sec. in the last 24 hours
  • Status/sec. in the last 24 hours
  • Total DDRs in the last 24 hours
  • Total DM DDRs in the last 24 hours
  • Total DM HINVs in the last 24 hours
  • Total DM ISAPI Requests Dispatched in the last 24 hours
  • Total DM ISAPI Requests Received in the last 24 hours
  • Total DM SINVs in the last 24 hours
  • Total DM Status in the last 24 hours
  • Total HINVs in the last 24 hours
  • Total Relay Reports in the last 24 hours
  • Total SINVs in the last 24 hours
  • Total Status in the last 24 hours

Processing Rates\Site Database Servers

  • SQL Server User connections in the last 24 hours

Processing Rates\Site Servers

  • DDRs/minute in the last 24 hours
  • HINVs/minute in the last 24 hours
  • SINVs/minute in the last 24 hours
  • Status/minute in the last 24 hours
  • SWMs/minute in the last 24 hours
  • Total DDRs in the last 24 hours
  • Total HINVs in the last 24 hours
  • Total SINVs in the last 24 hours
  • Total Status in the last 24 hours
  • Total SWMs in the last 24 hours

Vea también

Conceptos

Recursos adicionales para el módulo de administración de Microsoft Systems Management Server 2003
Sitios y componentes del módulo de administración de SMS 2003
Grupos de equipos para SMS 2003
Grupo de reglas de SMS 2003
Proveedores de SMS 2003
Secuencias de comandos de SMS 2003
Vistas de Microsoft SMS 2003
Diagramas de SMS 2003
Informes de SMS 2003


Diagramas de SMS 2003

El módulo de administración de SMS 2003 proporciona un diagrama de topología para la jerarquía de SMS. Los servidores de sitio y los sistemas de sitio se muestran con las relaciones que mantienen entre sí y con información contextual. En los diagramas de topología se incluyen datos lógicos (por ejemplo, jerarquías, sitios y datos físicos como servidores de sitio y sistemas de sitio). Puesto que las jerarquías de SMS 2003 pueden tener un tamaño considerable, puede limitar la vista de la jerarquía a cualquier grupo de equipos de SMS 2003 mediante el filtro Grupo.

La compatibilidad con los diagramas de topología para el módulo de administración de SMS 2003 de Operations Manager 2007 tiene los siguientes requisitos:

  • SMS 2003 SP3 instalado en servidores SMS en diagramas.
  • Se deben habilitar diagramas de topología.
  • Cada función de sitio se debe configurar con un nombre de dominio completo (FQDN) mediante la consola de administrador de SMS 2003.

Para que la detección de topología produzca un diagrama de la jerarquía de SMS 2003, se deben administrar los equipos del Proveedor de SMS, instalar un agente en estos equipos y habilitar el agente de conexiones proxy para otros equipos. Además, para que se muestren los conectores entre los servidores de sitio y los sistemas de sitio, los sistemas de sitio se deben haber detectado mediante un proceso de detección SMS y deben ser miembros de la colección All Systems.

La detección se realiza por sitio desde los sitios principales y los sitios secundarios se detectan como parte de la detección principal primaria. Los datos de detección se proporcionan mediante la información sobre herramientas y las anotaciones de servidor. Además, los diagramas se pueden exportar a un formato de archivo de Microsoft Visio®.

Anotaciones de imagen de topología de servidor SMS

Iconos para tipos de servidor

  • Tipo de servidor de base de datos: base de datos del sitio
  • Tipo de sistema de sitio: punto de administración
  • Tipo de servidor: sitio central, sitio principal, sitio secundario y sitio de sistema

Conectores

El estilo y el color del conector indican el tipo de relación entre los dos equipos:

  • El conector entre servidores de sitio es una línea sólida negra.
  • El conector entre un servidor de sitio y un sistema de sitio es una línea discontinua azul.

Vea también

Conceptos

Recursos adicionales para el módulo de administración de Microsoft Systems Management Server 2003
Sitios y componentes del módulo de administración de SMS 2003
Grupos de equipos para SMS 2003
Grupo de reglas de SMS 2003
Proveedores de SMS 2003
Secuencias de comandos de SMS 2003
Vistas de Microsoft SMS 2003
Diagramas de SMS 2003
Informes de SMS 2003


Informes de SMS 2003

Los informes descritos en esta sección están disponibles en el módulo de administración de SMS 2003. Informes es un componente opcional que se debe instalar de forma independiente. Para obtener más información acerca de la implementación del servidor de informes, consulte la página web de producto de Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Informes de SMS

El módulo de administración de Systems Management Server 2003 incluye tres tipos de informes:

  • Rendimiento
  • Configuración
  • Disponibilidad

Los informes se destinan a grupos y objetos mediante el selector de objetos. Todos los informes son informes vinculados que aprovechan las capacidades de informes de Operations Manager 2007. Puede elegir entre siete formatos exportables para los informes.

Informes de disponibilidad

Hay tres informes de Disponibilidad en el módulo de administración de SMS 2003. Para ejecutar estos informes en el grupo de destino del selector de objetos Microsoft.SMS.2003.ServersGroup seleccione el grupo de servidor SMS (Microsoft.SMS.2003.ServersGroup).

Informe de disponibilidad del servidor

El informe de disponibilidad del servidor se basa en el estado de mantenimiento agregado de todas las entidades de un servidor concreto. Este informe incluirá estados de mantenimiento para las funciones de monitor SMS y estados de mantenimiento de cualquier otra función supervisada.

Disponibilidad del servidor de sitio

El informe de disponibilidad del servidor de sitio se basa en el estado de mantenimiento de un servidor de sitio. Este informe usa información del monitor de estado.

Informe de disponibilidad de punto de administración

El informe de disponibilidad de punto de administración se basa en el estado de mantenimiento de un punto de administración. Este informe usa información del monitor de estado.

Informe de configuración

Hay un informe de configuración disponible con el módulo de administración de SMS 2003, el informe de configuración para clientes del servidor SMS 2003. Este informe es un informe de configuración personalizado básico que contiene propiedades para un servidor SMS o un grupo de servidores SMS.

El informe mostrará las siguiente propiedades de SMS:

  • Versión (versión del producto SMS)
  • Tipo de sistema de sitio (tipo de sistema de sitio, tipo de servidor, tipo de servidor de base de datos)
  • Componentes (servidor de sitio, punto de ubicación de servidor, punto de distribución, punto de administración, punto de notificación, servidor de base de datos, proveedor, remitente, punto de acceso cliente)
  • Código de sitio (código del sitio de SMS)
  • Tipo de servidor (servidor de sitio central, principal, secundario)
  • Nombre (nombre NetBIOS)
  • Tipo de servidor de base de datos (servidor de base de datos del sitio)

Este informe se puede ejecutar en el grupo de destino del selector de objetos Microsoft.SMS.2003.ServersGroup.

Rendimiento

Los informes de rendimiento se han agrupado en unidades basadas en la función de sitio que se está supervisando y, a continuación, en contadores en función de si son contadores de rendimiento relacionados con la velocidad (por ejemplo, por segundos o por minutos) o contadores sin formato (totales). Esta agrupación garantiza que todos los contadores de un informe usan una escala similar.

Los informes se han desarrollado según el tipo de análisis necesario. Hay dos conjuntos de informes disponibles según el tipo de análisis necesario. Un conjunto muestra todos los contadores de rendimiento para una función de servidor SMS concreta (por ejemplo, un punto de administración o un servidor de sitio). El segundo conjunto muestra todos los contadores de un objeto de procesamiento concreto (por ejemplo, inventario de hardware) para todas las funciones de sitio.

Informes de grupo de rendimiento del servidor SMS 2003

Para ejecutar los siguientes informes, seleccione Microsoft.SMS.2003.ServerPerformanceGroup en el grupo de destino del selector de objetos.

Rendimiento global del registro de datos de detección (DDR) de SMS 2003

Este informe muestra los trabajos acumulados del registro de detección de datos (DDR) y los totales procesados para todas las funciones de servidor SMS aplicables.

Medición del rendimiento de SMS 2003: Site Server DDR Backlog | DDR totales en cola
Medición del rendimiento de SMS 2003: DDR totales procesados del servidor de sitio | DDR totales procesados
Medición del rendimiento de SMS 2003: MP DDR Backlog | Mensajes en cola
Medición del rendimiento de SMS 2003: Adm. MP DDR (Total Reports) | Total Reports
Medición del rendimiento de SMS 2003: DDR totales procesados de DMP | Informes de detección totales generados

Rendimiento de velocidad del registro de detección de datos (DDR) de SMS 2003

Este informe muestra las velocidades de procesamiento del registro de detección de datos (DDR) para todas las funciones de servidor SMS aplicables.

Medición del rendimiento de SMS 2003: velocidad de procesamiento de DDR de servidor de sitio | DDR procesados/minuto
Medición del rendimiento de SMS 2003: Adm. MP DDR (Total Reports/sec) | Total Reports/sec
Medición del rendimiento de SMS 2003: velocidad de procesamiento de DMP DDR | Informes de detección generados/segundo

Rendimiento global del inventario de hardware (HINV) de SMS 2003

Este informe muestra los trabajos acumulados del inventario de hardware (HINV) y los totales procesados para todas las funciones de servidor SMS aplicables.

Medición del rendimiento de SMS 2003: Site Server HINV Backlog | MIF totales en cola
Medición del rendimiento de SMS 2003: HINV totales procesados del servidor de sitio | MIF totales procesados
Medición del rendimiento de SMS 2003: MP HINV Backlog | Mensajes en cola
Medición del rendimiento de SMS 2003: Adm. MP HINV (Total Reports) | Total Reports
Medición del rendimiento de SMS 2003: HINV totales procesados de DMP | Informes de inventario de hardware totales generados

Informe de velocidad del inventario de hardware (HINV) de SMS 2003

Este informe muestra las velocidades de procesamiento del inventario de hardware (HINV) para todas las funciones de servidor SMS aplicables.

Medición del rendimiento de SMS 2003: velocidad de procesamiento de HINV de servidor de sitio | MIF procesados/minuto
Medición del rendimiento de SMS 2003: Adm. MP HINV (Total Reports/sec) | Total Reports/sec
Medición del rendimiento de SMS 2003: Adm. reintentos de MP HINV (Total Reports/sec) | Total Reports/sec
Medición del rendimiento de SMS 2003: velocidad de procesamiento de DMP HINV | Informes de inventario de hardware generados/segundo

Rendimiento global del inventario de software (SINV) de SMS 2003

Este informe muestra los trabajos acumulados del inventario de software (SINV) y los totales procesados para todas las funciones de servidor SMS aplicables.

Medición del rendimiento de SMS 2003: Site Server SINV Backlog | SINV totales en cola
Medición del rendimiento de SMS 2003: SINV totales procesados de servidor de sitio | SINV totales procesados
Medición del rendimiento de SMS 2003: MP FileCollection Backlog | Mensajes en cola
Medición del rendimiento de SMS 2003: MP SINV Backlog | Mensajes en cola
Medición del rendimiento de SMS 2003: Adm. MP Sinv (Total Reports) | Total Reports
Medición del rendimiento de SMS 2003: SINV totales procesados de DMP | Informes de inventario de software totales generados

Rendimiento de velocidad del inventario de software (SINV) de SMS 2003

Este informe muestra las velocidades de procesamiento del inventario de software (SINV) para todas las funciones de servidor SMS aplicables.

Medición del rendimiento de SMS 2003: velocidad de procesamiento de SINV de servidor de sitio | SINV procesados/minuto
Medición del rendimiento de SMS 2003: Adm. MP Sinv (Total Reports/sec) | Total Reports/sec
Medición del rendimiento de SMS 2003: Adm. MP Sinv ColFile (Total Reports/sec) | Total Reports/sec
Medición del rendimiento de SMS 2003: velocidad de procesamiento de DMP SINV | Informes de inventario de software generados/segundo

Rendimiento de los recursos de sistema del servidor SMS 2003

Este informe muestra el uso de recursos del sistema por parte de las funciones de servidor SMS.

Medición del rendimiento de SMS 2003: memoria, % de bytes en uso confirmados | Bytes en uso confirmados
Medición del rendimiento de SMS 2003: archivo de paginación, % de uso | % de uso
Medición del rendimiento de SMS 2003: Procesador, % de tiempo de procesador (_Total) | % de tiempo de procesador
Medición del rendimiento de SMS 2003: Proceso, % de tiempo de procesador (smsexec) | % de tiempo de procesador
Medición del rendimiento de SMS 2003: Proceso, % de tiempo de procesador (ccmexec) | % de tiempo de procesador
Medición del rendimiento de SMS 2003: Sistema, tiempo de actividad del sistema | Tiempo de actividad del sistema

Rendimiento global de la disponibilidad de software (SWM) de SMS 2003

Este informe muestra los trabajos acumulados de la disponibilidad de software (SWM) y los totales procesados para todas las funciones de servidor SMS aplicables.

Medición del rendimiento de SMS 2003: Site Server SWM Backlog | Archivos de uso SWM totales en cola
Medición del rendimiento de SMS 2003: SWM totales procesados de servidor de sitio | Registros de uso SWM totales procesados
Medición del rendimiento de SMS 2003: MP Relay Mgr Backlog | Mensajes en cola
Medición del rendimiento de SMS 2003: Adm. relé MP (Total Reports) | Total Reports

Rendimiento de velocidad de la disponibilidad de software (SWM) de SMS 2003

Este informe muestra las velocidades de procesamiento de la disponibilidad de software (SWM) para todas las funciones de servidor SMS aplicables.

Medición del rendimiento de SMS 2003: velocidad de procesamiento SWM de servidor de sitio | Registros de uso SWM procesados/minuto
Medición del rendimiento de SMS 2003: Adm. relé MP (Total Reports/sec) | Total Reports/sec

Rendimiento global de mensajes de estado de SMS 2003

Este informe muestra los trabajos acumulados de SMS Status Message y los totales procesados para todas las funciones de servidor SMS aplicables.

Medición del rendimiento de SMS 2003: total de mensajes de estado procesados de servidor de sitio | Recibidos
Medición del rendimiento de SMS 2003: Trabajo acumulado de estado de MP | Mensajes en cola
Medición del rendimiento de SMS 2003: Adm. estado MP (sucesos totales) | Sucesos totales
Medición del rendimiento de SMS 2003: total de mensajes de estado procesados de DMP | Mensajes de estado totales generados

Rendimiento de velocidad de mensajes de estado de SMS 2003

Este informe muestra las velocidades de procesamiento de SMS Status Message para todas las funciones de servidor SMS aplicables.

Medición del rendimiento de SMS 2003: velocidad de procesamiento de estado de servidor de sitio | Procesados/segundo
Medición del rendimiento de SMS 2003: Adm. estado MP (eventos totales/segundo) | Sucesos totales/segundo
Medición del rendimiento de SMS 2003: velocidad de procesamiento de estado de DMP | Mensajes de estado generados/segundo

Rendimiento de las funciones de servidor compatibles con SMS 2003

Este informe muestra el rendimiento de los servicios que admiten las funciones de servidor SMS.

Medición del rendimiento de SMS 2003: servicio web (solicitudes de extensión ISAPI/segundo) | Solicitudes de extensión ISAPI/segundo
Medición del rendimiento de SMS 2003: conexiones de SQL de SMS | Conexiones de usuario

Informes de servidor de punto de administración de SMS 2003

Para ejecutar los siguientes informes, seleccione Microsoft Management Point Servers en el grupo de destino del selector de objetos.

Rendimiento global del punto de administración de dispositivos de SMS 2003

Este informe muestra los totales procesados para la función de servidor del punto de administración de dispositivos de SMS.

Medición del rendimiento de SMS 2003: DDR totales procesados de DMP | Informes de detección totales generados
Medición del rendimiento de SMS 2003: HINV totales procesados de DMP | Informes de inventario de hardware totales generados
Medición del rendimiento de SMS 2003: SINV totales procesados de DMP | Informes de inventario de software totales generados
Medición del rendimiento de SMS 2003: Mensajes de estado totales procesados de DMP | Mensajes de estado totales generados
Medición del rendimiento de SMS 2003: Solicitudes ISAPI totales de DMP distribuidas | Mensajes totales distribuidos
Medición del rendimiento de SMS 2003: solicitudes ISAPI totales de DMP recibidas | Mensajes totales recibidos

Rendimiento de velocidad del punto de administración de dispositivos de SMS 2003

Este informe muestra las velocidades de procesamiento para la función de servidor de punto de administración de dispositivos de SMS.

Medición del rendimiento de SMS 2003: velocidad de solicitudes de configuración DMP | Solicitudes de configuración DMP/segundo
Medición del rendimiento de SMS 2003: velocidad de solicitudes de configuración de equipo DMP | Solicitudes de configuración de equipo/segundo
Medición del rendimiento de SMS 2003: velocidad de solicitud de identificador de directivas de software DMP | Solicitudes de identificador de directivas de software/segundo
Medición del rendimiento de SMS 2003: velocidad de solicitud de cuerpo de directiva de software DMP | Solicitudes de cuerpo de directiva de software/segundo
Medición del rendimiento de SMS 2003: velocidad de solicitud de versión de paquete DMP | Solicitudes de versión de paquete/segundo
Medición del rendimiento de SMS 2003: velocidad de solicitud de conversión de detección DMP | Solicitudes de conversión de detección/segundo
Medición del rendimiento de SMS 2003: velocidad de solicitud de conversión de inventario de hardware DMP | Solicitudes de conversión de inventario de hardware/segundo
Medición del rendimiento de SMS 2003: velocidad de intento de conexión de base de datos DMP | Intentos de conexión de base de datos/segundo
Medición del rendimiento de SMS 2003: velocidad de procesamiento de DMP DDR | Informes de detección generados/segundo
Medición del rendimiento de SMS 2003: velocidad de procesamiento de DMP HINV | Informes de inventario de hardware generados/segundo
Medición del rendimiento de SMS 2003: velocidad de procesamiento de solicitud de ubicación DMP DP | Solicitudes de ubicación generadas/segundo
Medición del rendimiento de SMS 2003: velocidad de procesamiento de mensajes DMP ISAPI | Mensajes distribuidos/segundo
Medición del rendimiento de SMS 2003: velocidad de procesamiento de DMP SINV | Informes de inventario de software generados/segundo
Medición del rendimiento de SMS 2003: velocidad de procesamiento de estado de DMP | Mensajes de estado generados/segundo

Rendimiento global del punto de administración de SMS 2003

Este informe muestra los trabajos acumulados y totales procesados para la función de servidor de punto de administración de SMS.

Medición del rendimiento de SMS 2003: MP DDR Backlog | Mensajes en cola
Medición del rendimiento de SMS 2003: Adm. MP DDR (Total Reports) | Total Reports
Medición del rendimiento de SMS 2003: MP HINV Backlog | Mensajes en cola
Medición del rendimiento de SMS 2003: Adm. MP HINV (Total Reports) | Total Reports
Medición del rendimiento de SMS 2003: MP FileCollection Backlog | Mensajes en cola
Medición del rendimiento de SMS 2003: MP SINV Backlog | Mensajes en cola
Medición del rendimiento de SMS 2003: Adm. MP SINV (Total Reports) | Total Reports
Medición del rendimiento de SMS 2003: MP Relay Mgr Backlog | Mensajes en cola
Medición del rendimiento de SMS 2003: Adm. relé MP (Total Reports) | Total Reports
Medición del rendimiento de SMS 2003: Trabajo acumulado de estado de MP | Mensajes en cola
Medición del rendimiento de SMS 2003: Adm. estado MP (sucesos totales) | Sucesos totales

Rendimiento de velocidad del punto de administración de SMS 2003

Este informe muestra las velocidades de procesamiento para la función de servidor de punto de administración de dispositivos de SMS.

Medición del rendimiento de SMS 2003: Adm. ubicación MP (solicitudes MP/segundo) | Solicitudes MP/segundo
Medición del rendimiento de SMS 2003: Adm. ubicación MP (solicitudes DP/segundo) | Solicitudes DP/segundo
Medición del rendimiento de SMS 2003: directiva de obtención MP (solicitudes/segundo) | Solicitudes/segundo
Medición del rendimiento de SMS 2003: Aut. obtención MP (solicitudes/segundo) | Solicitudes/segundo
Medición del rendimiento de SMS 2003: Adm. directiva MP (solicitudes PA/segundo) | Solicitudes PA/segundo
Medición del rendimiento de SMS 2003: MP DAL (SP ejecutados/segundo) | SP ejecutados/segundo
Medición del rendimiento de SMS 2003: Adm. MP HINV (Total Reports/sec) | Total Reports/sec
Medición del rendimiento de SMS 2003: Adm. reintentos de MP HINV (Total Reports/sec) | Total Reports/sec
Medición del rendimiento de SMS 2003: Adm. MP SINV (Total Reports/sec) | Total Reports/sec
Medición del rendimiento de SMS 2003: Adm. MP SINV ColFile (Total Reports/sec) | Total Reports/sec
Medición del rendimiento de SMS 2003: Adm. relé MP (Total Reports/sec) | Total Reports/sec
Medición del rendimiento de SMS 2003: Adm. estado MP (eventos totales/segundo) | Sucesos totales/segundo

Vea también

Conceptos

Recursos adicionales para el módulo de administración de Microsoft Systems Management Server 2003
Sitios y componentes del módulo de administración de SMS 2003
Grupos de equipos para SMS 2003
Grupo de reglas de SMS 2003
Proveedores de SMS 2003
Secuencias de comandos de SMS 2003
Vistas de Microsoft SMS 2003
Diagramas de SMS 2003
Informes de SMS 2003